Make.spec
changeset 40 c99f058e2276
parent 39 d361eb9419e6
child 41 f3898a3b378d
equal deleted inserted replaced
39:d361eb9419e6 40:c99f058e2276
    49 # STCWARNINGS=-warnEOLComments
    49 # STCWARNINGS=-warnEOLComments
    50 STCWARNINGS=-warnNonStandard
    50 STCWARNINGS=-warnNonStandard
    51 
    51 
    52 COMMON_CLASSES= \
    52 COMMON_CLASSES= \
    53 	IRBuilder \
    53 	IRBuilder \
    54 	IRBuilderTest \
       
    55 	IRBytecodeGenerator \
    54 	IRBytecodeGenerator \
    56 	IRFunction \
    55 	IRFunction \
    57 	IRInstruction \
    56 	IRInstruction \
    58 	IRInterpreter \
    57 	IRInterpreter \
    59 	IRSequence \
    58 	IRSequence \
    60 	IRStackCount \
    59 	IRStackCount \
    61 	IRTransformTest \
       
    62 	cvut_stx_goodies_newcompiler \
    60 	cvut_stx_goodies_newcompiler \
    63 	IRAccess \
    61 	IRAccess \
    64 	IRClosure \
    62 	IRClosure \
    65 	IRConstant \
    63 	IRConstant \
    66 	IRDecompiler \
    64 	IRDecompiler \
    89 
    87 
    90 
    88 
    91 
    89 
    92 COMMON_OBJS= \
    90 COMMON_OBJS= \
    93     $(OUTDIR)IRBuilder.$(O) \
    91     $(OUTDIR)IRBuilder.$(O) \
    94     $(OUTDIR)IRBuilderTest.$(O) \
       
    95     $(OUTDIR)IRBytecodeGenerator.$(O) \
    92     $(OUTDIR)IRBytecodeGenerator.$(O) \
    96     $(OUTDIR)IRFunction.$(O) \
    93     $(OUTDIR)IRFunction.$(O) \
    97     $(OUTDIR)IRInstruction.$(O) \
    94     $(OUTDIR)IRInstruction.$(O) \
    98     $(OUTDIR)IRInterpreter.$(O) \
    95     $(OUTDIR)IRInterpreter.$(O) \
    99     $(OUTDIR)IRSequence.$(O) \
    96     $(OUTDIR)IRSequence.$(O) \
   100     $(OUTDIR)IRStackCount.$(O) \
    97     $(OUTDIR)IRStackCount.$(O) \
   101     $(OUTDIR)IRTransformTest.$(O) \
       
   102     $(OUTDIR)cvut_stx_goodies_newcompiler.$(O) \
    98     $(OUTDIR)cvut_stx_goodies_newcompiler.$(O) \
   103     $(OUTDIR)IRAccess.$(O) \
    99     $(OUTDIR)IRAccess.$(O) \
   104     $(OUTDIR)IRClosure.$(O) \
   100     $(OUTDIR)IRClosure.$(O) \
   105     $(OUTDIR)IRConstant.$(O) \
   101     $(OUTDIR)IRConstant.$(O) \
   106     $(OUTDIR)IRDecompiler.$(O) \
   102     $(OUTDIR)IRDecompiler.$(O) \