Make.spec
changeset 41 f3898a3b378d
parent 40 c99f058e2276
child 42 acdc3ec6d152
equal deleted inserted replaced
40:c99f058e2276 41:f3898a3b378d
     1 # $Header$
     1 # $Header$
     2 #
     2 #
     3 # DO NOT EDIT
     3 # DO NOT EDIT
     4 # automagically generated from the projectDefinition: cvut_stx_goodies_newcompiler.
     4 # automagically generated from the projectDefinition: ctu_ircompiler.
     5 #
     5 #
     6 # Warning: once you modify this file, do not rerun
     6 # Warning: once you modify this file, do not rerun
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     8 #
     8 #
     9 # This file contains specifications which are common to all platforms.
     9 # This file contains specifications which are common to all platforms.
    10 #
    10 #
    11 
    11 
    12 # Do NOT CHANGE THESE DEFINITIONS
    12 # Do NOT CHANGE THESE DEFINITIONS
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
    14 #  to find the source code of a class and to find the library for a package)
    14 #  to find the source code of a class and to find the library for a package)
    15 MODULE=cvut
    15 MODULE=ctu
    16 MODULE_DIR=stx/goodies/newcompiler
    16 MODULE_DIR=ircompiler
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    18 
    18 
    19 
    19 
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    21 #  -headerDir=. : create header files locally
    21 #  -headerDir=. : create header files locally
    55 	IRFunction \
    55 	IRFunction \
    56 	IRInstruction \
    56 	IRInstruction \
    57 	IRInterpreter \
    57 	IRInterpreter \
    58 	IRSequence \
    58 	IRSequence \
    59 	IRStackCount \
    59 	IRStackCount \
    60 	cvut_stx_goodies_newcompiler \
    60 	ctu_ircompiler \
    61 	IRAccess \
    61 	IRAccess \
    62 	IRClosure \
    62 	IRClosure \
    63 	IRConstant \
    63 	IRConstant \
    64 	IRDecompiler \
    64 	IRDecompiler \
    65 	IRDup \
    65 	IRDup \
    93     $(OUTDIR)IRFunction.$(O) \
    93     $(OUTDIR)IRFunction.$(O) \
    94     $(OUTDIR)IRInstruction.$(O) \
    94     $(OUTDIR)IRInstruction.$(O) \
    95     $(OUTDIR)IRInterpreter.$(O) \
    95     $(OUTDIR)IRInterpreter.$(O) \
    96     $(OUTDIR)IRSequence.$(O) \
    96     $(OUTDIR)IRSequence.$(O) \
    97     $(OUTDIR)IRStackCount.$(O) \
    97     $(OUTDIR)IRStackCount.$(O) \
    98     $(OUTDIR)cvut_stx_goodies_newcompiler.$(O) \
    98     $(OUTDIR)ctu_ircompiler.$(O) \
    99     $(OUTDIR)IRAccess.$(O) \
    99     $(OUTDIR)IRAccess.$(O) \
   100     $(OUTDIR)IRClosure.$(O) \
   100     $(OUTDIR)IRClosure.$(O) \
   101     $(OUTDIR)IRConstant.$(O) \
   101     $(OUTDIR)IRConstant.$(O) \
   102     $(OUTDIR)IRDecompiler.$(O) \
   102     $(OUTDIR)IRDecompiler.$(O) \
   103     $(OUTDIR)IRDup.$(O) \
   103     $(OUTDIR)IRDup.$(O) \