Make.spec
changeset 17 10d696c79188
parent 16 a5a8c0454395
child 18 6bf3d5c400d1
--- a/Make.spec	Wed Jun 18 10:50:49 2014 +0100
+++ b/Make.spec	Thu Jun 19 10:10:52 2014 +0100
@@ -59,31 +59,30 @@
 	GDBInternalPipeStream \
 	GDBLauncher \
 	GDBObject \
-	GDBObjectDescriptor \
-	GDBObjectDescriptorError \
 	GDBPTY \
-	GDBPropertyDescriptor \
+	GDBValueDescriptor \
+	GDBValueDescriptorError \
 	jv_libgdbs \
 	GDB \
 	GDBAsyncEvent \
 	GDBCLICommand \
 	GDBCommandEvent \
 	GDBCommandResultEvent \
-	GDBCompoundPropertyDescriptor \
+	GDBCompoundValueDescriptor \
 	GDBDriver \
-	GDBEnumPropertyDescriptor \
+	GDBEnumValueDescriptor \
 	GDBInternalEvent \
 	GDBMICommand \
 	GDBParser \
-	GDBPrimitivePropertyDescriptor \
+	GDBPrimitiveValueDescriptor \
 	GDBStreamOutputEvent \
-	GDBAddressPropertyDescriptor \
-	GDBBooleanPropertyDescriptor \
+	GDBAddresValueDescriptor \
+	GDBBooleanValueDescriptor \
 	GDBConsoleOutputEvent \
 	GDBExecutionEvent \
 	GDBExitEvent \
-	GDBIntegerPropertyDescriptor \
-	GDBListPropertyDescriptor \
+	GDBIntegerValueDescriptor \
+	GDBListValueDescriptor \
 	GDBLogOutputEvent \
 	GDBMI_ada_task_info \
 	GDBMI_add_inferior \
@@ -195,9 +194,9 @@
 	GDBMI_var_show_format \
 	GDBMI_var_update \
 	GDBNotificationEvent \
-	GDBObjectPropertyDescriptor \
+	GDBObjectValueDescriptor \
 	GDBStatusEvent \
-	GDBStringPropertyDescriptor \
+	GDBStringValueDescriptor \
 	GDBTargetOutputEvent \
 	GDBBreakpointCreatedEvent \
 	GDBBreakpointDeletedEvent \
@@ -225,31 +224,30 @@
     $(OUTDIR_SLASH)GDBInternalPipeStream.$(O) \
     $(OUTDIR_SLASH)GDBLauncher.$(O) \
     $(OUTDIR_SLASH)GDBObject.$(O) \
-    $(OUTDIR_SLASH)GDBObjectDescriptor.$(O) \
-    $(OUTDIR_SLASH)GDBObjectDescriptorError.$(O) \
     $(OUTDIR_SLASH)GDBPTY.$(O) \
-    $(OUTDIR_SLASH)GDBPropertyDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBValueDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBValueDescriptorError.$(O) \
     $(OUTDIR_SLASH)jv_libgdbs.$(O) \
     $(OUTDIR_SLASH)GDB.$(O) \
     $(OUTDIR_SLASH)GDBAsyncEvent.$(O) \
     $(OUTDIR_SLASH)GDBCLICommand.$(O) \
     $(OUTDIR_SLASH)GDBCommandEvent.$(O) \
     $(OUTDIR_SLASH)GDBCommandResultEvent.$(O) \
-    $(OUTDIR_SLASH)GDBCompoundPropertyDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBCompoundValueDescriptor.$(O) \
     $(OUTDIR_SLASH)GDBDriver.$(O) \
-    $(OUTDIR_SLASH)GDBEnumPropertyDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBEnumValueDescriptor.$(O) \
     $(OUTDIR_SLASH)GDBInternalEvent.$(O) \
     $(OUTDIR_SLASH)GDBMICommand.$(O) \
     $(OUTDIR_SLASH)GDBParser.$(O) \
-    $(OUTDIR_SLASH)GDBPrimitivePropertyDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBPrimitiveValueDescriptor.$(O) \
     $(OUTDIR_SLASH)GDBStreamOutputEvent.$(O) \
-    $(OUTDIR_SLASH)GDBAddressPropertyDescriptor.$(O) \
-    $(OUTDIR_SLASH)GDBBooleanPropertyDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBAddresValueDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBBooleanValueDescriptor.$(O) \
     $(OUTDIR_SLASH)GDBConsoleOutputEvent.$(O) \
     $(OUTDIR_SLASH)GDBExecutionEvent.$(O) \
     $(OUTDIR_SLASH)GDBExitEvent.$(O) \
-    $(OUTDIR_SLASH)GDBIntegerPropertyDescriptor.$(O) \
-    $(OUTDIR_SLASH)GDBListPropertyDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBIntegerValueDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBListValueDescriptor.$(O) \
     $(OUTDIR_SLASH)GDBLogOutputEvent.$(O) \
     $(OUTDIR_SLASH)GDBMI_ada_task_info.$(O) \
     $(OUTDIR_SLASH)GDBMI_add_inferior.$(O) \
@@ -361,9 +359,9 @@
     $(OUTDIR_SLASH)GDBMI_var_show_format.$(O) \
     $(OUTDIR_SLASH)GDBMI_var_update.$(O) \
     $(OUTDIR_SLASH)GDBNotificationEvent.$(O) \
-    $(OUTDIR_SLASH)GDBObjectPropertyDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBObjectValueDescriptor.$(O) \
     $(OUTDIR_SLASH)GDBStatusEvent.$(O) \
-    $(OUTDIR_SLASH)GDBStringPropertyDescriptor.$(O) \
+    $(OUTDIR_SLASH)GDBStringValueDescriptor.$(O) \
     $(OUTDIR_SLASH)GDBTargetOutputEvent.$(O) \
     $(OUTDIR_SLASH)GDBBreakpointCreatedEvent.$(O) \
     $(OUTDIR_SLASH)GDBBreakpointDeletedEvent.$(O) \
@@ -377,6 +375,7 @@
     $(OUTDIR_SLASH)GDBThreadGroupAddedEvent.$(O) \
     $(OUTDIR_SLASH)GDBThreadGroupExitedEvent.$(O) \
     $(OUTDIR_SLASH)GDBThreadGroupStartedEvent.$(O) \
+    $(OUTDIR_SLASH)extensions.$(O) \