Make.spec
changeset 0 739fe9b7253e
child 4 90de244a7fa2
equal deleted inserted replaced
-1:000000000000 0:739fe9b7253e
       
     1 # $Header: /cvs/stx/stx/goodies/petitparser/Make.spec,v 1.1 2011-08-18 18:56:17 cg Exp $
       
     2 #
       
     3 # DO NOT EDIT 
       
     4 # automagically generated from the projectDefinition: squeak_petitparser.
       
     5 #
       
     6 # Warning: once you modify this file, do not rerun
       
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
       
     8 #
       
     9 # This file contains specifications which are common to all platforms.
       
    10 #
       
    11 
       
    12 # Do NOT CHANGE THESE DEFINITIONS
       
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
       
    14 #  to find the source code of a class and to find the library for a package)
       
    15 MODULE=squeak
       
    16 MODULE_DIR=petitparser
       
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
       
    18 
       
    19 
       
    20 # Argument(s) to the stc compiler (stc --usage).
       
    21 #  -H.         : create header files locally
       
    22 #                (if removed, they will be created as common
       
    23 #  -Pxxx       : defines the package
       
    24 #  -Zxxx       : a prefix for variables within the classLib
       
    25 #  -Dxxx       : defines passed to to CC for inline C-code
       
    26 #  -Ixxx       : include path passed to CC for inline C-code
       
    27 #  +optspace   : optimized for space
       
    28 #  +optspace2  : optimized more for space
       
    29 #  +optspace3  : optimized even more for space
       
    30 #  +optinline  : generate inline code for some ST constructs
       
    31 #  +inlineNew  : additionally inline new
       
    32 #  +inlineMath : additionally inline some floatPnt math stuff
       
    33 #
       
    34 # ********** OPTIONAL: MODIFY the next line(s) ***
       
    35 # STCLOCALOPTIMIZATIONS=+optinline +inlineNew
       
    36 # STCLOCALOPTIMIZATIONS=+optspace3
       
    37 STCLOCALOPTIMIZATIONS=+optspace3
       
    38 
       
    39 
       
    40 # Argument(s) to the stc compiler (stc --usage).
       
    41 #  -warn            : no warnings
       
    42 #  -warnNonStandard : no warnings about ST/X extensions
       
    43 #  -warnEOLComments : no warnings about EOL comment extension
       
    44 #  -warnPrivacy     : no warnings about privateClass extension
       
    45 #
       
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
       
    47 # STCWARNINGS=-warn
       
    48 # STCWARNINGS=-warnNonStandard
       
    49 # STCWARNINGS=-warnEOLComments
       
    50 STCWARNINGS=-warnNonStandard
       
    51 
       
    52 COMMON_CLASSES= \
       
    53 	PPCharSetPredicate \
       
    54 	PPFailure \
       
    55 	PPMemento \
       
    56 	PPParser \
       
    57 	PPStream \
       
    58 	PPToken \
       
    59 	squeak_petitparser \
       
    60 	PPDelegateParser \
       
    61 	PPEpsilonParser \
       
    62 	PPFailingParser \
       
    63 	PPListParser \
       
    64 	PPLiteralParser \
       
    65 	PPPluggableParser \
       
    66 	PPPredicateParser \
       
    67 	PPUnresolvedParser \
       
    68 	PPActionParser \
       
    69 	PPAndParser \
       
    70 	PPChoiceParser \
       
    71 	PPCompositeParser \
       
    72 	PPEndOfInputParser \
       
    73 	PPExpressionParser \
       
    74 	PPFlattenParser \
       
    75 	PPLiteralObjectParser \
       
    76 	PPLiteralSequenceParser \
       
    77 	PPMemoizedParser \
       
    78 	PPNotParser \
       
    79 	PPOptionalParser \
       
    80 	PPPredicateObjectParser \
       
    81 	PPPredicateSequenceParser \
       
    82 	PPRepeatingParser \
       
    83 	PPSequenceParser \
       
    84 	PPTrimmingParser \
       
    85 	PPArithmeticParser \
       
    86 	PPLambdaParser \
       
    87 	PPTokenParser \
       
    88 	PPWrappingParser \
       
    89 
       
    90 
       
    91 
       
    92 
       
    93 COMMON_OBJS= \
       
    94     $(OUTDIR)PPCharSetPredicate.$(O) \
       
    95     $(OUTDIR)PPFailure.$(O) \
       
    96     $(OUTDIR)PPMemento.$(O) \
       
    97     $(OUTDIR)PPParser.$(O) \
       
    98     $(OUTDIR)PPStream.$(O) \
       
    99     $(OUTDIR)PPToken.$(O) \
       
   100     $(OUTDIR)squeak_petitparser.$(O) \
       
   101     $(OUTDIR)PPDelegateParser.$(O) \
       
   102     $(OUTDIR)PPEpsilonParser.$(O) \
       
   103     $(OUTDIR)PPFailingParser.$(O) \
       
   104     $(OUTDIR)PPListParser.$(O) \
       
   105     $(OUTDIR)PPLiteralParser.$(O) \
       
   106     $(OUTDIR)PPPluggableParser.$(O) \
       
   107     $(OUTDIR)PPPredicateParser.$(O) \
       
   108     $(OUTDIR)PPUnresolvedParser.$(O) \
       
   109     $(OUTDIR)PPActionParser.$(O) \
       
   110     $(OUTDIR)PPAndParser.$(O) \
       
   111     $(OUTDIR)PPChoiceParser.$(O) \
       
   112     $(OUTDIR)PPCompositeParser.$(O) \
       
   113     $(OUTDIR)PPEndOfInputParser.$(O) \
       
   114     $(OUTDIR)PPExpressionParser.$(O) \
       
   115     $(OUTDIR)PPFlattenParser.$(O) \
       
   116     $(OUTDIR)PPLiteralObjectParser.$(O) \
       
   117     $(OUTDIR)PPLiteralSequenceParser.$(O) \
       
   118     $(OUTDIR)PPMemoizedParser.$(O) \
       
   119     $(OUTDIR)PPNotParser.$(O) \
       
   120     $(OUTDIR)PPOptionalParser.$(O) \
       
   121     $(OUTDIR)PPPredicateObjectParser.$(O) \
       
   122     $(OUTDIR)PPPredicateSequenceParser.$(O) \
       
   123     $(OUTDIR)PPRepeatingParser.$(O) \
       
   124     $(OUTDIR)PPSequenceParser.$(O) \
       
   125     $(OUTDIR)PPTrimmingParser.$(O) \
       
   126     $(OUTDIR)PPArithmeticParser.$(O) \
       
   127     $(OUTDIR)PPLambdaParser.$(O) \
       
   128     $(OUTDIR)PPTokenParser.$(O) \
       
   129     $(OUTDIR)PPWrappingParser.$(O) \
       
   130     $(OUTDIR)extensions.$(O) \
       
   131 
       
   132 
       
   133