compiler/Make.spec
changeset 464 f6d77fee9811
parent 459 4751c407bb40
child 477 b18b6cc7aabc
child 502 1e45d3c96ec5
--- a/compiler/Make.spec	Tue May 12 01:24:03 2015 +0100
+++ b/compiler/Make.spec	Thu May 21 14:12:22 2015 +0100
@@ -55,7 +55,9 @@
 	PPCBridge \
 	PPCCompiledMethod \
 	PPCCompiler \
+	PPCCompilerTokenErrorStrategy \
 	PPCCompilerTokenRememberStrategy \
+	PPCCompilerTokenizingErrorStrategy \
 	PPCCompilerTokenizingRememberStrategy \
 	PPCConfiguration \
 	PPCContext \
@@ -65,31 +67,31 @@
 	PPCNode \
 	PPCNodeVisitor \
 	PPCPluggableConfiguration \
+	PPCTokenGuard \
 	PPCompiledParser \
 	stx_goodies_petitparser_compiler \
-	PPCAbstractCharacterNode \
 	PPCAbstractLiteralNode \
 	PPCAbstractPredicateNode \
 	PPCAnyNode \
+	PPCCharacterNode \
 	PPCCodeGenerator \
 	PPCDelegateNode \
 	PPCEndOfFileNode \
 	PPCInlinedMethod \
 	PPCInliningVisitor \
-	PPCLL1Configuration \
 	PPCListNode \
 	PPCNilNode \
 	PPCPluggableNode \
 	PPCProfilingContext \
 	PPCRewritingVisitor \
 	PPCTokenizingCompiler \
+	PPCTokenizingConfiguration \
 	PPCUniversalConfiguration \
 	PPCUnknownNode \
 	PPTokenizingCompiledParser \
 	PPCAbstractActionNode \
 	PPCAndNode \
 	PPCCharSetPredicateNode \
-	PPCCharacterNode \
 	PPCChoiceNode \
 	PPCCopyVisitor \
 	PPCEndOfInputNode \
@@ -100,6 +102,7 @@
 	PPCMessagePredicateNode \
 	PPCNegateNode \
 	PPCNotCharSetPredicateNode \
+	PPCNotCharacterNode \
 	PPCNotLiteralNode \
 	PPCNotMessagePredicateNode \
 	PPCNotNode \
@@ -132,6 +135,7 @@
 	PPCSymbolActionNode \
 	PPCTokenChoiceNode \
 	PPCTrimNode \
+	PPCTrimmingCharacterTokenNode \
 	PPCTokenStarMessagePredicateNode \
 	PPCTokenStarSeparatorNode \
 
@@ -143,7 +147,9 @@
     $(OUTDIR_SLASH)PPCBridge.$(O) \
     $(OUTDIR_SLASH)PPCCompiledMethod.$(O) \
     $(OUTDIR_SLASH)PPCCompiler.$(O) \
+    $(OUTDIR_SLASH)PPCCompilerTokenErrorStrategy.$(O) \
     $(OUTDIR_SLASH)PPCCompilerTokenRememberStrategy.$(O) \
+    $(OUTDIR_SLASH)PPCCompilerTokenizingErrorStrategy.$(O) \
     $(OUTDIR_SLASH)PPCCompilerTokenizingRememberStrategy.$(O) \
     $(OUTDIR_SLASH)PPCConfiguration.$(O) \
     $(OUTDIR_SLASH)PPCContext.$(O) \
@@ -153,31 +159,31 @@
     $(OUTDIR_SLASH)PPCNode.$(O) \
     $(OUTDIR_SLASH)PPCNodeVisitor.$(O) \
     $(OUTDIR_SLASH)PPCPluggableConfiguration.$(O) \
+    $(OUTDIR_SLASH)PPCTokenGuard.$(O) \
     $(OUTDIR_SLASH)PPCompiledParser.$(O) \
     $(OUTDIR_SLASH)stx_goodies_petitparser_compiler.$(O) \
-    $(OUTDIR_SLASH)PPCAbstractCharacterNode.$(O) \
     $(OUTDIR_SLASH)PPCAbstractLiteralNode.$(O) \
     $(OUTDIR_SLASH)PPCAbstractPredicateNode.$(O) \
     $(OUTDIR_SLASH)PPCAnyNode.$(O) \
+    $(OUTDIR_SLASH)PPCCharacterNode.$(O) \
     $(OUTDIR_SLASH)PPCCodeGenerator.$(O) \
     $(OUTDIR_SLASH)PPCDelegateNode.$(O) \
     $(OUTDIR_SLASH)PPCEndOfFileNode.$(O) \
     $(OUTDIR_SLASH)PPCInlinedMethod.$(O) \
     $(OUTDIR_SLASH)PPCInliningVisitor.$(O) \
-    $(OUTDIR_SLASH)PPCLL1Configuration.$(O) \
     $(OUTDIR_SLASH)PPCListNode.$(O) \
     $(OUTDIR_SLASH)PPCNilNode.$(O) \
     $(OUTDIR_SLASH)PPCPluggableNode.$(O) \
     $(OUTDIR_SLASH)PPCProfilingContext.$(O) \
     $(OUTDIR_SLASH)PPCRewritingVisitor.$(O) \
     $(OUTDIR_SLASH)PPCTokenizingCompiler.$(O) \
+    $(OUTDIR_SLASH)PPCTokenizingConfiguration.$(O) \
     $(OUTDIR_SLASH)PPCUniversalConfiguration.$(O) \
     $(OUTDIR_SLASH)PPCUnknownNode.$(O) \
     $(OUTDIR_SLASH)PPTokenizingCompiledParser.$(O) \
     $(OUTDIR_SLASH)PPCAbstractActionNode.$(O) \
     $(OUTDIR_SLASH)PPCAndNode.$(O) \
     $(OUTDIR_SLASH)PPCCharSetPredicateNode.$(O) \
-    $(OUTDIR_SLASH)PPCCharacterNode.$(O) \
     $(OUTDIR_SLASH)PPCChoiceNode.$(O) \
     $(OUTDIR_SLASH)PPCCopyVisitor.$(O) \
     $(OUTDIR_SLASH)PPCEndOfInputNode.$(O) \
@@ -188,6 +194,7 @@
     $(OUTDIR_SLASH)PPCMessagePredicateNode.$(O) \
     $(OUTDIR_SLASH)PPCNegateNode.$(O) \
     $(OUTDIR_SLASH)PPCNotCharSetPredicateNode.$(O) \
+    $(OUTDIR_SLASH)PPCNotCharacterNode.$(O) \
     $(OUTDIR_SLASH)PPCNotLiteralNode.$(O) \
     $(OUTDIR_SLASH)PPCNotMessagePredicateNode.$(O) \
     $(OUTDIR_SLASH)PPCNotNode.$(O) \
@@ -220,6 +227,7 @@
     $(OUTDIR_SLASH)PPCSymbolActionNode.$(O) \
     $(OUTDIR_SLASH)PPCTokenChoiceNode.$(O) \
     $(OUTDIR_SLASH)PPCTrimNode.$(O) \
+    $(OUTDIR_SLASH)PPCTrimmingCharacterTokenNode.$(O) \
     $(OUTDIR_SLASH)PPCTokenStarMessagePredicateNode.$(O) \
     $(OUTDIR_SLASH)PPCTokenStarSeparatorNode.$(O) \
     $(OUTDIR_SLASH)extensions.$(O) \