terminals/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Wed, 01 Feb 2012 00:41:14 +0000
changeset 99 677c81c943e4
parent 96 85e395d8e3d7
child 103 726bf2ca0b99
permissions -rw-r--r--
build files regenerated

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_xtreams_terminals at 2012-02-01 00:32:11.389.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/xtreams/terminals
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	Xtreams::BlockClosureGenerateStream \
	Xtreams::BlockClosureReadStream \
	Xtreams::BlockClosureWriteStream \
	Xtreams::BufferReadStream \
	Xtreams::BufferWriteStream \
	Xtreams::BufferedWriteStream \
	Xtreams::CollectionWriteStream \
	Xtreams::ExternalReadStream \
	Xtreams::ExternalWriteStream \
	Xtreams::FileWriteStream \
	Xtreams::NullWriteStream \
	Xtreams::PointerReadStream \
	Xtreams::PointerWriteStream \
	Xtreams::SequenceableCollectionReadStream \
	Xtreams::SequenceableCollectionWriteStream \
	Xtreams::SharedQueueReadStream \
	Xtreams::SharedQueueWriteStream \
	stx_goodies_xtreams_terminals \
	Xtreams::FileReadStream \




COMMON_OBJS= \
    $(OUTDIR)Xtreams__BlockClosureGenerateStream.$(O) \
    $(OUTDIR)Xtreams__BlockClosureReadStream.$(O) \
    $(OUTDIR)Xtreams__BlockClosureWriteStream.$(O) \
    $(OUTDIR)Xtreams__BufferReadStream.$(O) \
    $(OUTDIR)Xtreams__BufferWriteStream.$(O) \
    $(OUTDIR)Xtreams__BufferedWriteStream.$(O) \
    $(OUTDIR)Xtreams__CollectionWriteStream.$(O) \
    $(OUTDIR)Xtreams__ExternalReadStream.$(O) \
    $(OUTDIR)Xtreams__ExternalWriteStream.$(O) \
    $(OUTDIR)Xtreams__FileWriteStream.$(O) \
    $(OUTDIR)Xtreams__NullWriteStream.$(O) \
    $(OUTDIR)Xtreams__PointerReadStream.$(O) \
    $(OUTDIR)Xtreams__PointerWriteStream.$(O) \
    $(OUTDIR)Xtreams__SequenceableCollectionReadStream.$(O) \
    $(OUTDIR)Xtreams__SequenceableCollectionWriteStream.$(O) \
    $(OUTDIR)Xtreams__SharedQueueReadStream.$(O) \
    $(OUTDIR)Xtreams__SharedQueueWriteStream.$(O) \
    $(OUTDIR)stx_goodies_xtreams_terminals.$(O) \
    $(OUTDIR)Xtreams__FileReadStream.$(O) \
    $(OUTDIR)extensions.$(O) \