terminals/Make.spec
author Martin Kobetic
Sun, 17 Nov 2013 00:23:18 -0500
changeset 147 bd6be28aa924
parent 109 9587e2df7029
permissions -rw-r--r--
merging

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_xtreams_terminals.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/xtreams/terminals
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	Xtreams::BlockClosureGenerateStream \
	Xtreams::BlockClosureReadStream \
	Xtreams::BlockClosureWriteStream \
	Xtreams::BufferReadStream \
	Xtreams::BufferWriteStream \
	Xtreams::BufferedWriteStream \
	Xtreams::CollectionWriteStream \
	Xtreams::ExternalReadStream \
	Xtreams::ExternalWriteStream \
	Xtreams::FileWriteStream \
	Xtreams::NullWriteStream \
	Xtreams::SequenceableCollectionReadStream \
	Xtreams::SequenceableCollectionWriteStream \
	Xtreams::SharedQueueReadStream \
	Xtreams::SharedQueueWriteStream \
	stx_goodies_xtreams_terminals \
	Xtreams::FileReadStream \




COMMON_OBJS= \
    $(OUTDIR_SLASH)Xtreams__BlockClosureGenerateStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__BlockClosureReadStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__BlockClosureWriteStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__BufferReadStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__BufferWriteStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__BufferedWriteStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__CollectionWriteStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__ExternalReadStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__ExternalWriteStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__FileWriteStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__NullWriteStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__SequenceableCollectionReadStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__SequenceableCollectionWriteStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__SharedQueueReadStream.$(O) \
    $(OUTDIR_SLASH)Xtreams__SharedQueueWriteStream.$(O) \
    $(OUTDIR_SLASH)stx_goodies_xtreams_terminals.$(O) \
    $(OUTDIR_SLASH)Xtreams__FileReadStream.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \