Make.spec
changeset 14390 19f86d68ea7b
parent 14283 3da874c60737
child 14462 df66322b976f
equal deleted inserted replaced
14389:f3f0359eddd1 14390:19f86d68ea7b
     1 # $Header: /cvs/stx/stx/libbasic/Make.spec,v 1.136 2012-08-03 09:40:45 vrany Exp $
     1 # $Header: /cvs/stx/stx/libbasic/Make.spec,v 1.137 2012-10-18 13:48:44 stefan Exp $
     2 #
     2 #
     3 # DO NOT EDIT
     3 # DO NOT EDIT
     4 # automagically generated from the projectDefinition: stx_libbasic at 2012-07-11 18:41:08.105.
     4 # automagically generated from the projectDefinition: stx_libbasic.
     5 #
     5 #
     6 # Warning: once you modify this file, do not rerun
     6 # Warning: once you modify this file, do not rerun
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     8 #
     8 #
     9 # This file contains specifications which are common to all platforms.
     9 # This file contains specifications which are common to all platforms.
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
    47 # STCWARNINGS=-warn
    47 # STCWARNINGS=-warn
    48 # STCWARNINGS=-warnNonStandard
    48 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnEOLComments
    49 # STCWARNINGS=-warnEOLComments
    50 STCWARNINGS=-warnNonStandard
    50 STCWARNINGS=-warnNonStandard
       
    51 
       
    52 UNIX_CLASSES= \
       
    53 	UnixFileDescriptorHandle \
       
    54 	UnixFileHandle \
       
    55 	UnixOperatingSystem \
    51 
    56 
    52 COMMON_CLASSES= \
    57 COMMON_CLASSES= \
    53 	Autoload \
    58 	Autoload \
    54 	Object \
    59 	Object \
    55 	ProtoObject \
    60 	ProtoObject \
   163 	True \
   168 	True \
   164 	UnixFilename \
   169 	UnixFilename \
   165 	WeakInterestConverter \
   170 	WeakInterestConverter \
   166 	ArrayedCollection \
   171 	ArrayedCollection \
   167 	UninterpretedBytes \
   172 	UninterpretedBytes \
       
   173 	AbstractNumberVector \
   168 	Association \
   174 	Association \
   169 	Block \
   175 	Block \
   170 	CharacterEncoderImplementations::ASCII \
   176 	CharacterEncoderImplementations::ASCII \
   171 	CharacterEncoderImplementations::ISO10646_to_UTF8 \
   177 	CharacterEncoderImplementations::ISO10646_to_UTF8 \
   172 	CharacterEncoderImplementations::ISO8859_9 \
   178 	CharacterEncoderImplementations::ISO8859_9 \
   189 	HaltInterrupt \
   195 	HaltInterrupt \
   190 	IdentitySet \
   196 	IdentitySet \
   191 	LinkedList \
   197 	LinkedList \
   192 	MD5Stream \
   198 	MD5Stream \
   193 	Method \
   199 	Method \
   194 	MethodWithBreakpoints \
       
   195 	MethodDictionary \
   200 	MethodDictionary \
   196 	Number \
   201 	Number \
   197 	MetaNumber \
   202 	MetaNumber \
   198 	SomeNumber \
   203 	SomeNumber \
   199 	Infinity \
   204 	Infinity \
   219 	Array \
   224 	Array \
   220 	BreakPointInterrupt \
   225 	BreakPointInterrupt \
   221 	CheapBlock \
   226 	CheapBlock \
   222 	Class \
   227 	Class \
   223 	ClassBuildError \
   228 	ClassBuildError \
   224 	AbstractNumberVector \
   229 	DoubleArray \
   225 	ElementBoundsError \
   230 	ElementBoundsError \
   226 	FileDirectory \
   231 	FileDirectory \
   227 	FloatArray \
   232 	FloatArray \
   228 	Fraction \
   233 	Fraction \
   229 	IdentityDictionary \
   234 	IdentityDictionary \
   244 	SignalSet \
   249 	SignalSet \
   245 	SnapshotError \
   250 	SnapshotError \
   246 	SortedCollection \
   251 	SortedCollection \
   247 	StringCollection \
   252 	StringCollection \
   248 	TerminateProcessRequest \
   253 	TerminateProcessRequest \
   249 	DoubleArray \
       
   250 	UserConfirmation \
   254 	UserConfirmation \
   251 	UserInformation \
   255 	UserInformation \
   252 	VMInternalError \
   256 	VMInternalError \
   253 	VarArgBlock \
   257 	VarArgBlock \
   254 	Warning \
   258 	Warning \
   366 	AbortAllOperationWantedQuery \
   370 	AbortAllOperationWantedQuery \
   367 	Complex \
   371 	Complex \
   368 	ConfigurableFeatures \
   372 	ConfigurableFeatures \
   369 	FileDoesNotExistException \
   373 	FileDoesNotExistException \
   370 	MiniLogger \
   374 	MiniLogger \
       
   375 	MethodWithBreakpoints \
       
   376 	IsDebuggingQuery \
   371 
   377 
   372 WIN32_CLASSES= \
   378 WIN32_CLASSES= \
   373 	Win32Process \
   379 	Win32Process \
   374 	PCFilename \
   380 	PCFilename \
   375 	Win32Handle \
   381 	Win32Handle \
   376 	Win32FILEHandle \
   382 	Win32FILEHandle \
   377 	Win32Constants \
   383 	Win32Constants \
   378 	Win32OperatingSystem \
   384 	Win32OperatingSystem \
   379 
   385 
   380 UNIX_CLASSES= \
   386 
   381        UnixFileDescriptorHandle \
   387 
   382        UnixFileHandle \
   388 
   383        UnixOperatingSystem \
   389 UNIX_OBJS= \
   384 
   390     $(OUTDIR)UnixFileDescriptorHandle.$(O) \
   385 
   391     $(OUTDIR)UnixFileHandle.$(O) \
       
   392     $(OUTDIR)UnixOperatingSystem.$(O) \
   386 
   393 
   387 COMMON_OBJS= \
   394 COMMON_OBJS= \
   388     $(OUTDIR)Autoload.$(O) \
   395     $(OUTDIR)Autoload.$(O) \
   389     $(OUTDIR)Object.$(O) \
   396     $(OUTDIR)Object.$(O) \
   390     $(OUTDIR)ProtoObject.$(O) \
   397     $(OUTDIR)ProtoObject.$(O) \
   498     $(OUTDIR)True.$(O) \
   505     $(OUTDIR)True.$(O) \
   499     $(OUTDIR)UnixFilename.$(O) \
   506     $(OUTDIR)UnixFilename.$(O) \
   500     $(OUTDIR)WeakInterestConverter.$(O) \
   507     $(OUTDIR)WeakInterestConverter.$(O) \
   501     $(OUTDIR)ArrayedCollection.$(O) \
   508     $(OUTDIR)ArrayedCollection.$(O) \
   502     $(OUTDIR)UninterpretedBytes.$(O) \
   509     $(OUTDIR)UninterpretedBytes.$(O) \
       
   510     $(OUTDIR)AbstractNumberVector.$(O) \
   503     $(OUTDIR)Association.$(O) \
   511     $(OUTDIR)Association.$(O) \
   504     $(OUTDIR)Block.$(O) \
   512     $(OUTDIR)Block.$(O) \
   505     $(OUTDIR)CharacterEncoderImplementations__ASCII.$(O) \
   513     $(OUTDIR)CharacterEncoderImplementations__ASCII.$(O) \
   506     $(OUTDIR)CharacterEncoderImplementations__ISO10646_to_UTF8.$(O) \
   514     $(OUTDIR)CharacterEncoderImplementations__ISO10646_to_UTF8.$(O) \
   507     $(OUTDIR)CharacterEncoderImplementations__ISO8859_9.$(O) \
   515     $(OUTDIR)CharacterEncoderImplementations__ISO8859_9.$(O) \
   524     $(OUTDIR)HaltInterrupt.$(O) \
   532     $(OUTDIR)HaltInterrupt.$(O) \
   525     $(OUTDIR)IdentitySet.$(O) \
   533     $(OUTDIR)IdentitySet.$(O) \
   526     $(OUTDIR)LinkedList.$(O) \
   534     $(OUTDIR)LinkedList.$(O) \
   527     $(OUTDIR)MD5Stream.$(O) \
   535     $(OUTDIR)MD5Stream.$(O) \
   528     $(OUTDIR)Method.$(O) \
   536     $(OUTDIR)Method.$(O) \
   529     $(OUTDIR)MethodWithBreakpoints.$(O) \
       
   530     $(OUTDIR)MethodDictionary.$(O) \
   537     $(OUTDIR)MethodDictionary.$(O) \
   531     $(OUTDIR)Number.$(O) \
   538     $(OUTDIR)Number.$(O) \
   532     $(OUTDIR)MetaNumber.$(O) \
   539     $(OUTDIR)MetaNumber.$(O) \
   533     $(OUTDIR)SomeNumber.$(O) \
   540     $(OUTDIR)SomeNumber.$(O) \
   534     $(OUTDIR)Infinity.$(O) \
   541     $(OUTDIR)Infinity.$(O) \
   554     $(OUTDIR)Array.$(O) \
   561     $(OUTDIR)Array.$(O) \
   555     $(OUTDIR)BreakPointInterrupt.$(O) \
   562     $(OUTDIR)BreakPointInterrupt.$(O) \
   556     $(OUTDIR)CheapBlock.$(O) \
   563     $(OUTDIR)CheapBlock.$(O) \
   557     $(OUTDIR)Class.$(O) \
   564     $(OUTDIR)Class.$(O) \
   558     $(OUTDIR)ClassBuildError.$(O) \
   565     $(OUTDIR)ClassBuildError.$(O) \
   559     $(OUTDIR)AbstractNumberVector.$(O) \
   566     $(OUTDIR)DoubleArray.$(O) \
   560     $(OUTDIR)ElementBoundsError.$(O) \
   567     $(OUTDIR)ElementBoundsError.$(O) \
   561     $(OUTDIR)FileDirectory.$(O) \
   568     $(OUTDIR)FileDirectory.$(O) \
   562     $(OUTDIR)FloatArray.$(O) \
   569     $(OUTDIR)FloatArray.$(O) \
   563     $(OUTDIR)Fraction.$(O) \
   570     $(OUTDIR)Fraction.$(O) \
   564     $(OUTDIR)IdentityDictionary.$(O) \
   571     $(OUTDIR)IdentityDictionary.$(O) \
   579     $(OUTDIR)SignalSet.$(O) \
   586     $(OUTDIR)SignalSet.$(O) \
   580     $(OUTDIR)SnapshotError.$(O) \
   587     $(OUTDIR)SnapshotError.$(O) \
   581     $(OUTDIR)SortedCollection.$(O) \
   588     $(OUTDIR)SortedCollection.$(O) \
   582     $(OUTDIR)StringCollection.$(O) \
   589     $(OUTDIR)StringCollection.$(O) \
   583     $(OUTDIR)TerminateProcessRequest.$(O) \
   590     $(OUTDIR)TerminateProcessRequest.$(O) \
   584     $(OUTDIR)DoubleArray.$(O) \
       
   585     $(OUTDIR)UserConfirmation.$(O) \
   591     $(OUTDIR)UserConfirmation.$(O) \
   586     $(OUTDIR)UserInformation.$(O) \
   592     $(OUTDIR)UserInformation.$(O) \
   587     $(OUTDIR)VMInternalError.$(O) \
   593     $(OUTDIR)VMInternalError.$(O) \
   588     $(OUTDIR)VarArgBlock.$(O) \
   594     $(OUTDIR)VarArgBlock.$(O) \
   589     $(OUTDIR)Warning.$(O) \
   595     $(OUTDIR)Warning.$(O) \
   701     $(OUTDIR)AbortAllOperationWantedQuery.$(O) \
   707     $(OUTDIR)AbortAllOperationWantedQuery.$(O) \
   702     $(OUTDIR)Complex.$(O) \
   708     $(OUTDIR)Complex.$(O) \
   703     $(OUTDIR)ConfigurableFeatures.$(O) \
   709     $(OUTDIR)ConfigurableFeatures.$(O) \
   704     $(OUTDIR)FileDoesNotExistException.$(O) \
   710     $(OUTDIR)FileDoesNotExistException.$(O) \
   705     $(OUTDIR)MiniLogger.$(O) \
   711     $(OUTDIR)MiniLogger.$(O) \
       
   712     $(OUTDIR)MethodWithBreakpoints.$(O) \
       
   713     $(OUTDIR)IsDebuggingQuery.$(O) \
   706 
   714 
   707 WIN32_OBJS= \
   715 WIN32_OBJS= \
   708     $(OUTDIR)Win32Process.$(O) \
   716     $(OUTDIR)Win32Process.$(O) \
   709     $(OUTDIR)PCFilename.$(O) \
   717     $(OUTDIR)PCFilename.$(O) \
   710     $(OUTDIR)Win32Handle.$(O) \
   718     $(OUTDIR)Win32Handle.$(O) \
   711     $(OUTDIR)Win32FILEHandle.$(O) \
   719     $(OUTDIR)Win32FILEHandle.$(O) \
   712     $(OUTDIR)Win32Constants.$(O) \
   720     $(OUTDIR)Win32Constants.$(O) \
   713     $(OUTDIR)Win32OperatingSystem.$(O) \
   721     $(OUTDIR)Win32OperatingSystem.$(O) \
   714 
   722 
   715 
   723 
   716 UNIX_OBJS= \
   724 
   717     $(OUTDIR)UnixFileDescriptorHandle.$(O) \
       
   718     $(OUTDIR)UnixFileHandle.$(O) \
       
   719     $(OUTDIR)UnixOperatingSystem.$(O) \
       
   720