Make.spec
changeset 14390 19f86d68ea7b
parent 14283 3da874c60737
child 14462 df66322b976f
--- a/Make.spec	Thu Oct 18 15:31:55 2012 +0200
+++ b/Make.spec	Thu Oct 18 15:48:44 2012 +0200
@@ -1,7 +1,7 @@
-# $Header: /cvs/stx/stx/libbasic/Make.spec,v 1.136 2012-08-03 09:40:45 vrany Exp $
+# $Header: /cvs/stx/stx/libbasic/Make.spec,v 1.137 2012-10-18 13:48:44 stefan Exp $
 #
 # DO NOT EDIT
-# automagically generated from the projectDefinition: stx_libbasic at 2012-07-11 18:41:08.105.
+# automagically generated from the projectDefinition: stx_libbasic.
 #
 # Warning: once you modify this file, do not rerun
 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
@@ -49,6 +49,11 @@
 # STCWARNINGS=-warnEOLComments
 STCWARNINGS=-warnNonStandard
 
+UNIX_CLASSES= \
+	UnixFileDescriptorHandle \
+	UnixFileHandle \
+	UnixOperatingSystem \
+
 COMMON_CLASSES= \
 	Autoload \
 	Object \
@@ -165,6 +170,7 @@
 	WeakInterestConverter \
 	ArrayedCollection \
 	UninterpretedBytes \
+	AbstractNumberVector \
 	Association \
 	Block \
 	CharacterEncoderImplementations::ASCII \
@@ -191,7 +197,6 @@
 	LinkedList \
 	MD5Stream \
 	Method \
-	MethodWithBreakpoints \
 	MethodDictionary \
 	Number \
 	MetaNumber \
@@ -221,7 +226,7 @@
 	CheapBlock \
 	Class \
 	ClassBuildError \
-	AbstractNumberVector \
+	DoubleArray \
 	ElementBoundsError \
 	FileDirectory \
 	FloatArray \
@@ -246,7 +251,6 @@
 	SortedCollection \
 	StringCollection \
 	TerminateProcessRequest \
-	DoubleArray \
 	UserConfirmation \
 	UserInformation \
 	VMInternalError \
@@ -368,6 +372,8 @@
 	ConfigurableFeatures \
 	FileDoesNotExistException \
 	MiniLogger \
+	MethodWithBreakpoints \
+	IsDebuggingQuery \
 
 WIN32_CLASSES= \
 	Win32Process \
@@ -377,12 +383,13 @@
 	Win32Constants \
 	Win32OperatingSystem \
 
-UNIX_CLASSES= \
-       UnixFileDescriptorHandle \
-       UnixFileHandle \
-       UnixOperatingSystem \
+
 
 
+UNIX_OBJS= \
+    $(OUTDIR)UnixFileDescriptorHandle.$(O) \
+    $(OUTDIR)UnixFileHandle.$(O) \
+    $(OUTDIR)UnixOperatingSystem.$(O) \
 
 COMMON_OBJS= \
     $(OUTDIR)Autoload.$(O) \
@@ -500,6 +507,7 @@
     $(OUTDIR)WeakInterestConverter.$(O) \
     $(OUTDIR)ArrayedCollection.$(O) \
     $(OUTDIR)UninterpretedBytes.$(O) \
+    $(OUTDIR)AbstractNumberVector.$(O) \
     $(OUTDIR)Association.$(O) \
     $(OUTDIR)Block.$(O) \
     $(OUTDIR)CharacterEncoderImplementations__ASCII.$(O) \
@@ -526,7 +534,6 @@
     $(OUTDIR)LinkedList.$(O) \
     $(OUTDIR)MD5Stream.$(O) \
     $(OUTDIR)Method.$(O) \
-    $(OUTDIR)MethodWithBreakpoints.$(O) \
     $(OUTDIR)MethodDictionary.$(O) \
     $(OUTDIR)Number.$(O) \
     $(OUTDIR)MetaNumber.$(O) \
@@ -556,7 +563,7 @@
     $(OUTDIR)CheapBlock.$(O) \
     $(OUTDIR)Class.$(O) \
     $(OUTDIR)ClassBuildError.$(O) \
-    $(OUTDIR)AbstractNumberVector.$(O) \
+    $(OUTDIR)DoubleArray.$(O) \
     $(OUTDIR)ElementBoundsError.$(O) \
     $(OUTDIR)FileDirectory.$(O) \
     $(OUTDIR)FloatArray.$(O) \
@@ -581,7 +588,6 @@
     $(OUTDIR)SortedCollection.$(O) \
     $(OUTDIR)StringCollection.$(O) \
     $(OUTDIR)TerminateProcessRequest.$(O) \
-    $(OUTDIR)DoubleArray.$(O) \
     $(OUTDIR)UserConfirmation.$(O) \
     $(OUTDIR)UserInformation.$(O) \
     $(OUTDIR)VMInternalError.$(O) \
@@ -703,6 +709,8 @@
     $(OUTDIR)ConfigurableFeatures.$(O) \
     $(OUTDIR)FileDoesNotExistException.$(O) \
     $(OUTDIR)MiniLogger.$(O) \
+    $(OUTDIR)MethodWithBreakpoints.$(O) \
+    $(OUTDIR)IsDebuggingQuery.$(O) \
 
 WIN32_OBJS= \
     $(OUTDIR)Win32Process.$(O) \
@@ -713,8 +721,4 @@
     $(OUTDIR)Win32OperatingSystem.$(O) \
 
 
-UNIX_OBJS= \
-    $(OUTDIR)UnixFileDescriptorHandle.$(O) \
-    $(OUTDIR)UnixFileHandle.$(O) \
-    $(OUTDIR)UnixOperatingSystem.$(O) \