Make.spec
changeset 1658 d85c2f344d08
parent 1654 eb2d904aa2ca
child 1672 463ee28f18fe
--- a/Make.spec	Wed Aug 23 11:08:24 2006 +0200
+++ b/Make.spec	Wed Aug 23 11:08:26 2006 +0200
@@ -1,98 +1,128 @@
-# $Header: /cvs/stx/stx/libbasic2/Make.spec,v 1.24 2006-08-18 11:49:47 cg Exp $
+# $Header: /cvs/stx/stx/libbasic2/Make.spec,v 1.25 2006-08-23 09:08:26 cg Exp $
+#
+# DO NOT EDIT 
+# automagically generated from the projectDefinition: stx_libbasic2.
+#
+# Warning: once you modify this file, do not rerun
+# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
+#
+# This file contains specifications which are common to all platforms.
 #
 
+# Do NOT CHANGE THESE DEFINITIONS
+# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
+#  to find the source code of a class and to find the library for a package)
 MODULE=stx
 MODULE_DIR=libbasic2
+PACKAGE=$(MODULE):$(MODULE_DIR)
 LIBNAME=libstx_libbasic2
-THIS_IS_A_BASE_LIBRARY="yes"
-PACKAGE=$(MODULE):$(MODULE_DIR)
+
+
+# Argument(s) to the stc compiler (stc --usage).
+#  -H.         : create header files locally
+#                (if removed, they will be created as common
+#  -Pxxx       : defines the package
+#  -Zxxx       : a prefix for variables within the classLib
+#  -Dxxx       : defines passed to to CC for inline C-code
+#  -Ixxx       : include path passed to CC for inline C-code
+#  +optspace   : optimized for space
+#  +optspace2  : optimized more for space
+#  +optspace3  : optimized even more for space
+#  +optinline  : generate inline code for some ST constructs
+#  +inlineNew  : additionally inline new
+#  +inlineMath : additionally inline some floatPnt math stuff
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
+# STCLOCALOPTIMIZATIONS=+optspace3
+STCLOCALOPTIMIZATIONS=+optspace2 -warnNonStandard
+
+
+# Argument(s) to the stc compiler (stc --usage).
+#  -warn            : no warnings
+#  -warnNonStandard : no warnings about ST/X extensions
+#  -warnEOLComments : no warnings about EOL comment extension
+#  -warnPrivacy     : no warnings about privateClass extension
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCWARNINGS=-warn
+# STCWARNINGS=-warnNonStandard
+# STCWARNINGS=-warnEOLComments
+STCWARNINGS=
 
 UNIX_OBJS= \
-	  $(OUTDIR)ZipStream.$(O)   \
-	  $(OUTDIR)BZip2Stream.$(O) \
-	  $(OUTDIR)Archiver.$(O)    \
+    Archiver.$(O) \
+    BZip2Stream.$(O) \
+    ZipStream.$(O) \
 
 
 WIN32_OBJS= \
-	  $(OUTDIR)SerialPort.$(O)  \
-
-
-#
-# these are uncritical - save some bytes by compiling with optspace
-#
-UNCRITICALOBJS=\
-	$(OUTDIR)HandlerCollection.$(O)          \
-	$(OUTDIR)MessageChannel.$(O)             \
-	$(OUTDIR)Promise.$(O)                    \
-	$(OUTDIR)SequenceableCollectionSorter.$(O) \
-	$(OUTDIR)UnitConverter.$(O)              \
-	$(OUTDIR)JISEncodedString.$(O)           \
-	$(OUTDIR)PrinterStream.$(O)              \
-	  $(OUTDIR)PostscriptPrinterStream.$(O)  \
+    SerialPort.$(O) \
 
 
-OBJS=\
-	$(OUTDIR)Base64Coder.$(O)       \
-	$(OUTDIR)FileSorter.$(O)        \
-	$(OUTDIR)MappedCollection.$(O)  \
-	$(OUTDIR)TwoByteString.$(O)     \
-	  $(OUTDIR)Unicode16String.$(O) \
-	  $(OUTDIR)JISEncodedString.$(O)         \
-	$(OUTDIR)FourByteString.$(O)    \
-	  $(OUTDIR)Unicode32String.$(O) \
-	$(OUTDIR)Polygon.$(O)           \
-	$(OUTDIR)List.$(O)              \
-	$(OUTDIR)Queue.$(O)             \
-	$(OUTDIR)SharedQueue.$(O)       \
-	$(OUTDIR)CacheDictionary.$(O)   \
-	$(OUTDIR)CacheDictionaryWithFactory.$(O) \
-	$(OUTDIR)RunArray.$(O)          \
-	$(OUTDIR)SharedCollection.$(O)	\
-	$(OUTDIR)Iterator.$(O)          \
-	$(OUTDIR)OrderedSet.$(O)        \
-	$(OUTDIR)OrderedDictionary.$(O) \
-	$(OUTDIR)Text.$(O)              \
-	$(OUTDIR)Socket.$(O)            \
-	$(OUTDIR)SocketAddress.$(O)     \
-	  $(OUTDIR)IPSocketAddress.$(O) \
-	  $(OUTDIR)IPv6SocketAddress.$(O)        \
-	  $(OUTDIR)UDSocketAddress.$(O) \
-	$(OUTDIR)SocketAddressInfo.$(O) \
-	$(OUTDIR)NameLookupError.$(O)   \
-	  $(OUTDIR)HostNameLookupError.$(O)      \
-	  $(OUTDIR)HostAddressLookupError.$(O)   \
-	$(OUTDIR)ActorStream.$(O)       \
-	$(OUTDIR)SoundStream.$(O)       \
-	$(OUTDIR)PrinterStream.$(O)     \
-	  $(OUTDIR)PostscriptPrinterStream.$(O)  \
-	$(OUTDIR)TextStream.$(O)        \
-	$(OUTDIR)UnitConverter.$(O)     \
-	$(OUTDIR)Random.$(O)            \
-	$(OUTDIR)RandomGenerator.$(O)            \
-	$(OUTDIR)UnboxedIntegerArray.$(O)        \
-	  $(OUTDIR)WordArray.$(O)       \
-	  $(OUTDIR)SignedWordArray.$(O) \
-	  $(OUTDIR)IntegerArray.$(O)    \
-	  $(OUTDIR)SignedIntegerArray.$(O)       \
-	  $(OUTDIR)LongIntegerArray.$(O)         \
-	  $(OUTDIR)SignedLongIntegerArray.$(O)   \
-	$(OUTDIR)ZipArchive.$(O)        \
-	$(OUTDIR)DirectoryContents.$(O) \
-	$(OUTDIR)BooleanArray.$(O)      \
-	$(OUTDIR)BitArray.$(O)          \
-	$(OUTDIR)Monitor.$(O)           \
-	$(OUTDIR)TimeDuration.$(O)      \
-	$(OUTDIR)Stack.$(O)             \
-	$(OUTDIR)CompressionStream.$(O) \
-	$(OUTDIR)UndoSupport.$(O)       \
-	$(OUTDIR)UUID.$(O)              \
-	$(OUTDIR)URI.$(O)               \
-	  $(OUTDIR)HierarchicalURI.$(O) \
-	    $(OUTDIR)FileURI.$(O)       \
-	    $(OUTDIR)FtpURI.$(O)        \
-	    $(OUTDIR)HttpURI.$(O)       \
-	$(OUTDIR)Promise.$(O)           \
-	$(OUTDIR)TimedPromise.$(O)      \
-	$(OUTDIR)Singleton.$(O)         \
-	$(SYSDEP_OBJS)                  \
-	$(LIBBASIC2_PACKAGE_OBJS)
+COMMON_OBJS= \
+    ActorStream.$(O) \
+    Base64Coder.$(O) \
+    BooleanArray.$(O) \
+    BitArray.$(O) \
+    CacheDictionary.$(O) \
+    CacheDictionaryWithFactory.$(O) \
+    CompressionStream.$(O) \
+    DirectoryContents.$(O) \
+    FileSorter.$(O) \
+    URI.$(O) \
+    FourByteString.$(O) \
+    HierarchicalURI.$(O) \
+    FtpURI.$(O) \
+    NameLookupError.$(O) \
+    HostNameLookupError.$(O) \
+    HttpURI.$(O) \
+    SocketAddress.$(O) \
+    IPSocketAddress.$(O) \
+    UnboxedIntegerArray.$(O) \
+    Iterator.$(O) \
+    TwoByteString.$(O) \
+    List.$(O) \
+    LongIntegerArray.$(O) \
+    MappedCollection.$(O) \
+    Monitor.$(O) \
+    HostAddressLookupError.$(O) \
+    OrderedDictionary.$(O) \
+    OrderedSet.$(O) \
+    Polygon.$(O) \
+    PrinterStream.$(O) \
+    PostscriptPrinterStream.$(O) \
+    Promise.$(O) \
+    Queue.$(O) \
+    Random.$(O) \
+    RandomGenerator.$(O) \
+    RunArray.$(O) \
+    SharedCollection.$(O) \
+    SharedQueue.$(O) \
+    SignedIntegerArray.$(O) \
+    SignedLongIntegerArray.$(O) \
+    SignedWordArray.$(O) \
+    Singleton.$(O) \
+    Socket.$(O) \
+    IPv6SocketAddress.$(O) \
+    SocketAddressInfo.$(O) \
+    SoundStream.$(O) \
+    Stack.$(O) \
+    Text.$(O) \
+    TextStream.$(O) \
+    TimeDuration.$(O) \
+    TimedPromise.$(O) \
+    JISEncodedString.$(O) \
+    UDSocketAddress.$(O) \
+    FileURI.$(O) \
+    UUID.$(O) \
+    IntegerArray.$(O) \
+    UndoSupport.$(O) \
+    Unicode16String.$(O) \
+    Unicode32String.$(O) \
+    UnitConverter.$(O) \
+    WordArray.$(O) \
+    ZipArchive.$(O) \
+    stx_libbasic2.$(O) \
+
+