Make.spec
changeset 4490 b6ec72aeb053
parent 3817 fbba5477af34
child 4723 524785227024
equal deleted inserted replaced
4489:e96387661c07 4490:b6ec72aeb053
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    21 #  -headerDir=. : create header files locally
    21 #  -headerDir=. : create header files locally
    22 #                (if removed, they will be created as common
    22 #                (if removed, they will be created as common
    23 #  -Pxxx       : defines the package
    23 #  -Pxxx       : defines the package
    24 #  -Zxxx       : a prefix for variables within the classLib
    24 #  -Zxxx       : a prefix for variables within the classLib
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    25 #  -Dxxx       : defines passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    27 #  +optspace   : optimized for space
    27 #  +optspace   : optimized for space
    28 #  +optspace2  : optimized more for space
    28 #  +optspace2  : optimized more for space
    29 #  +optspace3  : optimized even more for space
    29 #  +optspace3  : optimized even more for space
    30 #  +optinline  : generate inline code for some ST constructs
    30 #  +optinline  : generate inline code for some ST constructs
    54 	Breakpoint \
    54 	Breakpoint \
    55 	BreakpointDescription \
    55 	BreakpointDescription \
    56 	BreakpointQuery \
    56 	BreakpointQuery \
    57 	CompilationErrorHandler \
    57 	CompilationErrorHandler \
    58 	CompilationErrorHandlerQuery \
    58 	CompilationErrorHandlerQuery \
       
    59 	DoEnableCompilerOptionActionQuery \
    59 	DoNotShowCompilerWarningAgainActionQuery \
    60 	DoNotShowCompilerWarningAgainActionQuery \
    60 	DoNotShowCompilerWarningAgainForThisMethodActionQuery \
    61 	DoNotShowCompilerWarningAgainForThisMethodActionQuery \
    61 	DoNotShowCompilerWarningAgainForThisReceiverSelectorActionQuery \
    62 	DoNotShowCompilerWarningAgainForThisReceiverSelectorActionQuery \
    62 	InstrumentationContext \
    63 	InstrumentationContext \
    63 	InstrumentationInfo \
    64 	InstrumentationInfo \
   120 
   121 
   121 
   122 
   122 
   123 
   123 
   124 
   124 COMMON_OBJS= \
   125 COMMON_OBJS= \
   125     $(OUTDIR_SLASH)Breakpoint.$(O) \
   126     $(OUTDIR)Breakpoint.$(O) \
   126     $(OUTDIR_SLASH)BreakpointDescription.$(O) \
   127     $(OUTDIR)BreakpointDescription.$(O) \
   127     $(OUTDIR_SLASH)BreakpointQuery.$(O) \
   128     $(OUTDIR)BreakpointQuery.$(O) \
   128     $(OUTDIR_SLASH)CompilationErrorHandler.$(O) \
   129     $(OUTDIR)CompilationErrorHandler.$(O) \
   129     $(OUTDIR_SLASH)CompilationErrorHandlerQuery.$(O) \
   130     $(OUTDIR)CompilationErrorHandlerQuery.$(O) \
   130     $(OUTDIR_SLASH)DoNotShowCompilerWarningAgainActionQuery.$(O) \
   131     $(OUTDIR)DoEnableCompilerOptionActionQuery.$(O) \
   131     $(OUTDIR_SLASH)DoNotShowCompilerWarningAgainForThisMethodActionQuery.$(O) \
   132     $(OUTDIR)DoNotShowCompilerWarningAgainActionQuery.$(O) \
   132     $(OUTDIR_SLASH)DoNotShowCompilerWarningAgainForThisReceiverSelectorActionQuery.$(O) \
   133     $(OUTDIR)DoNotShowCompilerWarningAgainForThisMethodActionQuery.$(O) \
   133     $(OUTDIR_SLASH)InstrumentationContext.$(O) \
   134     $(OUTDIR)DoNotShowCompilerWarningAgainForThisReceiverSelectorActionQuery.$(O) \
   134     $(OUTDIR_SLASH)InstrumentationInfo.$(O) \
   135     $(OUTDIR)InstrumentationContext.$(O) \
   135     $(OUTDIR_SLASH)InstrumentedMethod.$(O) \
   136     $(OUTDIR)InstrumentationInfo.$(O) \
   136     $(OUTDIR_SLASH)LazyMethod.$(O) \
   137     $(OUTDIR)InstrumentedMethod.$(O) \
   137     $(OUTDIR_SLASH)ObjectFileHandle.$(O) \
   138     $(OUTDIR)LazyMethod.$(O) \
   138     $(OUTDIR_SLASH)ObjectFileLoader.$(O) \
   139     $(OUTDIR)ObjectFileHandle.$(O) \
   139     $(OUTDIR_SLASH)ParseError.$(O) \
   140     $(OUTDIR)ObjectFileLoader.$(O) \
   140     $(OUTDIR_SLASH)ParseNode.$(O) \
   141     $(OUTDIR)ParseError.$(O) \
   141     $(OUTDIR_SLASH)ParseNodeVisitor.$(O) \
   142     $(OUTDIR)ParseNode.$(O) \
   142     $(OUTDIR_SLASH)ParseWarning.$(O) \
   143     $(OUTDIR)ParseNodeVisitor.$(O) \
   143     $(OUTDIR_SLASH)ParserFlags.$(O) \
   144     $(OUTDIR)ParseWarning.$(O) \
   144     $(OUTDIR_SLASH)ProgramNodeBuilder.$(O) \
   145     $(OUTDIR)ParserFlags.$(O) \
   145     $(OUTDIR_SLASH)ProgramNodeEnumerator.$(O) \
   146     $(OUTDIR)ProgramNodeBuilder.$(O) \
   146     $(OUTDIR_SLASH)STCCompilerInterface.$(O) \
   147     $(OUTDIR)ProgramNodeEnumerator.$(O) \
   147     $(OUTDIR_SLASH)Scanner.$(O) \
   148     $(OUTDIR)STCCompilerInterface.$(O) \
   148     $(OUTDIR_SLASH)SourceFileLoader.$(O) \
   149     $(OUTDIR)Scanner.$(O) \
   149     $(OUTDIR_SLASH)Structure.$(O) \
   150     $(OUTDIR)SourceFileLoader.$(O) \
   150     $(OUTDIR_SLASH)UndefinedVariable.$(O) \
   151     $(OUTDIR)Structure.$(O) \
   151     $(OUTDIR_SLASH)UndefinedVariableNotification.$(O) \
   152     $(OUTDIR)UndefinedVariable.$(O) \
   152     $(OUTDIR_SLASH)Variable.$(O) \
   153     $(OUTDIR)UndefinedVariableNotification.$(O) \
   153     $(OUTDIR_SLASH)stx_libcomp.$(O) \
   154     $(OUTDIR)Variable.$(O) \
   154     $(OUTDIR_SLASH)AssignmentNode.$(O) \
   155     $(OUTDIR)stx_libcomp.$(O) \
   155     $(OUTDIR_SLASH)BlockNode.$(O) \
   156     $(OUTDIR)AssignmentNode.$(O) \
   156     $(OUTDIR_SLASH)BreakpointNode.$(O) \
   157     $(OUTDIR)BlockNode.$(O) \
   157     $(OUTDIR_SLASH)CompilationError.$(O) \
   158     $(OUTDIR)BreakpointNode.$(O) \
   158     $(OUTDIR_SLASH)EvalScriptingErrorHandler.$(O) \
   159     $(OUTDIR)CompilationError.$(O) \
   159     $(OUTDIR_SLASH)MessageNode.$(O) \
   160     $(OUTDIR)EvalScriptingErrorHandler.$(O) \
   160     $(OUTDIR_SLASH)MethodNode.$(O) \
   161     $(OUTDIR)MessageNode.$(O) \
   161     $(OUTDIR_SLASH)ParseErrorNode.$(O) \
   162     $(OUTDIR)MethodNode.$(O) \
   162     $(OUTDIR_SLASH)Parser.$(O) \
   163     $(OUTDIR)ParseErrorNode.$(O) \
   163     $(OUTDIR_SLASH)PluggableParseNodeVisitor.$(O) \
   164     $(OUTDIR)Parser.$(O) \
   164     $(OUTDIR_SLASH)PrimaryNode.$(O) \
   165     $(OUTDIR)PluggableParseNodeVisitor.$(O) \
   165     $(OUTDIR_SLASH)ProgramNode.$(O) \
   166     $(OUTDIR)PrimaryNode.$(O) \
   166     $(OUTDIR_SLASH)SelectorNode.$(O) \
   167     $(OUTDIR)ProgramNode.$(O) \
   167     $(OUTDIR_SLASH)StatementNode.$(O) \
   168     $(OUTDIR)SelectorNode.$(O) \
   168     $(OUTDIR_SLASH)TextCollectingCompilationErrorHandler.$(O) \
   169     $(OUTDIR)StatementNode.$(O) \
   169     $(OUTDIR_SLASH)UndefinedSuperclassError.$(O) \
   170     $(OUTDIR)TextCollectingCompilationErrorHandler.$(O) \
   170     $(OUTDIR_SLASH)UndefinedVariableError.$(O) \
   171     $(OUTDIR)UndefinedSuperclassError.$(O) \
   171     $(OUTDIR_SLASH)WarningCompilationErrorHandler.$(O) \
   172     $(OUTDIR)UndefinedVariableError.$(O) \
   172     $(OUTDIR_SLASH)AbstractSyntaxHighlighter.$(O) \
   173     $(OUTDIR)WarningCompilationErrorHandler.$(O) \
   173     $(OUTDIR_SLASH)BinaryNode.$(O) \
   174     $(OUTDIR)AbstractSyntaxHighlighter.$(O) \
   174     $(OUTDIR_SLASH)BreakpointAnalyzer.$(O) \
   175     $(OUTDIR)BinaryNode.$(O) \
   175     $(OUTDIR_SLASH)ByteCodeCompiler.$(O) \
   176     $(OUTDIR)BreakpointAnalyzer.$(O) \
   176     $(OUTDIR_SLASH)CascadeNode.$(O) \
   177     $(OUTDIR)ByteCodeCompiler.$(O) \
   177     $(OUTDIR_SLASH)ConstantNode.$(O) \
   178     $(OUTDIR)CascadeNode.$(O) \
   178     $(OUTDIR_SLASH)Explainer.$(O) \
   179     $(OUTDIR)ConstantNode.$(O) \
   179     $(OUTDIR_SLASH)PrimitiveNode.$(O) \
   180     $(OUTDIR)Explainer.$(O) \
   180     $(OUTDIR_SLASH)ReturnNode.$(O) \
   181     $(OUTDIR)PrimitiveNode.$(O) \
   181     $(OUTDIR_SLASH)SelfNode.$(O) \
   182     $(OUTDIR)ReturnNode.$(O) \
   182     $(OUTDIR_SLASH)UnaryNode.$(O) \
   183     $(OUTDIR)SelfNode.$(O) \
   183     $(OUTDIR_SLASH)VariableNode.$(O) \
   184     $(OUTDIR)UnaryNode.$(O) \
   184     $(OUTDIR_SLASH)ByteCodeCompilerWithBreakpointSupport.$(O) \
   185     $(OUTDIR)VariableNode.$(O) \
   185     $(OUTDIR_SLASH)CodeCoverageHighlighter.$(O) \
   186     $(OUTDIR)ByteCodeCompilerWithBreakpointSupport.$(O) \
   186     $(OUTDIR_SLASH)Decompiler.$(O) \
   187     $(OUTDIR)CodeCoverageHighlighter.$(O) \
   187     $(OUTDIR_SLASH)ECompletionConstantNode.$(O) \
   188     $(OUTDIR)Decompiler.$(O) \
   188     $(OUTDIR_SLASH)InstrumentingCompiler.$(O) \
   189     $(OUTDIR)ECompletionConstantNode.$(O) \
   189     $(OUTDIR_SLASH)SuperNode.$(O) \
   190     $(OUTDIR)InstrumentingCompiler.$(O) \
   190     $(OUTDIR_SLASH)SyntaxHighlighter.$(O) \
   191     $(OUTDIR)SuperNode.$(O) \
   191     $(OUTDIR_SLASH)extensions.$(O) \
   192     $(OUTDIR)SyntaxHighlighter.$(O) \
       
   193     $(OUTDIR)extensions.$(O) \
   192 
   194 
   193 
   195 
   194 
   196