Make.spec
author Jan Vrany <jan.vrany@labware.com>
Thu, 27 Oct 2022 14:53:59 +0100
branchjv
changeset 4735 3b11fb3ede98
parent 4723 524785227024
permissions -rw-r--r--
Allow single underscore as method / block argument and temporaries This commit is a follow up for 38b221e.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libcomp.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libcomp
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optinline +optinline2 +inlinenew


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard -warnUnused

COMMON_CLASSES= \
	Breakpoint \
	BreakpointDescription \
	BreakpointQuery \
	CompilationErrorHandler \
	CompilationErrorHandlerQuery \
	DoEnableCompilerOptionActionQuery \
	DIEntry \
	DIInfoVersions \
	DISectionTypes \
	DoNotShowCompilerWarningAgainActionQuery \
	DoNotShowCompilerWarningAgainForThisMethodActionQuery \
	DoNotShowCompilerWarningAgainForThisReceiverSelectorActionQuery \
	InstrumentationContext \
	InstrumentationInfo \
	InstrumentedMethod \
	LazyMethod \
	ObjectFileHandle \
	ObjectFileLoader \
	ParseError \
	ParseNode \
	ParseNodeVisitor \
	ParseWarning \
	ParserFlags \
	ProgramNodeBuilder \
	ProgramNodeEnumerator \
	STCCompilerInterface \
	Scanner \
	SourceFileLoader \
	Structure \
	UndefinedVariable \
	UndefinedVariableNotification \
	Variable \
	stx_libcomp \
	AssignmentNode \
	BlockNode \
	BreakpointNode \
	CompilationError \
	DIInfo \
	DISection \
	DIVariable \
	EvalScriptingErrorHandler \
	MessageNode \
	MethodNode \
	ParseErrorNode \
	Parser \
	PluggableParseNodeVisitor \
	PrimaryNode \
	ProgramNode \
	SelectorNode \
	StatementNode \
	TextCollectingCompilationErrorHandler \
	UndefinedSuperclassError \
	UndefinedVariableError \
	WarningCompilationErrorHandler \
	AbstractSyntaxHighlighter \
	BinaryNode \
	BreakpointAnalyzer \
	ByteCodeCompiler \
	CascadeNode \
	ConstantNode \
	DIVariableTable \
	Explainer \
	PrimitiveNode \
	ReturnNode \
	SelfNode \
	UnaryNode \
	VariableNode \
	ByteCodeCompilerWithBreakpointSupport \
	CodeCoverageHighlighter \
	Decompiler \
	ECompletionConstantNode \
	InstrumentingCompiler \
	SuperNode \
	SyntaxHighlighter \




COMMON_OBJS= \
    $(OUTDIR)Breakpoint.$(O) \
    $(OUTDIR)BreakpointDescription.$(O) \
    $(OUTDIR)BreakpointQuery.$(O) \
    $(OUTDIR)CompilationErrorHandler.$(O) \
    $(OUTDIR)CompilationErrorHandlerQuery.$(O) \
    $(OUTDIR)DoEnableCompilerOptionActionQuery.$(O) \
    $(OUTDIR)DIEntry.$(O) \
    $(OUTDIR)DIInfoVersions.$(O) \
    $(OUTDIR)DISectionTypes.$(O) \
    $(OUTDIR)DoNotShowCompilerWarningAgainActionQuery.$(O) \
    $(OUTDIR)DoNotShowCompilerWarningAgainForThisMethodActionQuery.$(O) \
    $(OUTDIR)DoNotShowCompilerWarningAgainForThisReceiverSelectorActionQuery.$(O) \
    $(OUTDIR)InstrumentationContext.$(O) \
    $(OUTDIR)InstrumentationInfo.$(O) \
    $(OUTDIR)InstrumentedMethod.$(O) \
    $(OUTDIR)LazyMethod.$(O) \
    $(OUTDIR)ObjectFileHandle.$(O) \
    $(OUTDIR)ObjectFileLoader.$(O) \
    $(OUTDIR)ParseError.$(O) \
    $(OUTDIR)ParseNode.$(O) \
    $(OUTDIR)ParseNodeVisitor.$(O) \
    $(OUTDIR)ParseWarning.$(O) \
    $(OUTDIR)ParserFlags.$(O) \
    $(OUTDIR)ProgramNodeBuilder.$(O) \
    $(OUTDIR)ProgramNodeEnumerator.$(O) \
    $(OUTDIR)STCCompilerInterface.$(O) \
    $(OUTDIR)Scanner.$(O) \
    $(OUTDIR)SourceFileLoader.$(O) \
    $(OUTDIR)Structure.$(O) \
    $(OUTDIR)UndefinedVariable.$(O) \
    $(OUTDIR)UndefinedVariableNotification.$(O) \
    $(OUTDIR)Variable.$(O) \
    $(OUTDIR)stx_libcomp.$(O) \
    $(OUTDIR)AssignmentNode.$(O) \
    $(OUTDIR)BlockNode.$(O) \
    $(OUTDIR)BreakpointNode.$(O) \
    $(OUTDIR)CompilationError.$(O) \
    $(OUTDIR)DIInfo.$(O) \
    $(OUTDIR)DISection.$(O) \
    $(OUTDIR)DIVariable.$(O) \
    $(OUTDIR)EvalScriptingErrorHandler.$(O) \
    $(OUTDIR)MessageNode.$(O) \
    $(OUTDIR)MethodNode.$(O) \
    $(OUTDIR)ParseErrorNode.$(O) \
    $(OUTDIR)Parser.$(O) \
    $(OUTDIR)PluggableParseNodeVisitor.$(O) \
    $(OUTDIR)PrimaryNode.$(O) \
    $(OUTDIR)ProgramNode.$(O) \
    $(OUTDIR)SelectorNode.$(O) \
    $(OUTDIR)StatementNode.$(O) \
    $(OUTDIR)TextCollectingCompilationErrorHandler.$(O) \
    $(OUTDIR)UndefinedSuperclassError.$(O) \
    $(OUTDIR)UndefinedVariableError.$(O) \
    $(OUTDIR)WarningCompilationErrorHandler.$(O) \
    $(OUTDIR)AbstractSyntaxHighlighter.$(O) \
    $(OUTDIR)BinaryNode.$(O) \
    $(OUTDIR)BreakpointAnalyzer.$(O) \
    $(OUTDIR)ByteCodeCompiler.$(O) \
    $(OUTDIR)CascadeNode.$(O) \
    $(OUTDIR)ConstantNode.$(O) \
    $(OUTDIR)DIVariableTable.$(O) \
    $(OUTDIR)Explainer.$(O) \
    $(OUTDIR)PrimitiveNode.$(O) \
    $(OUTDIR)ReturnNode.$(O) \
    $(OUTDIR)SelfNode.$(O) \
    $(OUTDIR)UnaryNode.$(O) \
    $(OUTDIR)VariableNode.$(O) \
    $(OUTDIR)ByteCodeCompilerWithBreakpointSupport.$(O) \
    $(OUTDIR)CodeCoverageHighlighter.$(O) \
    $(OUTDIR)Decompiler.$(O) \
    $(OUTDIR)ECompletionConstantNode.$(O) \
    $(OUTDIR)InstrumentingCompiler.$(O) \
    $(OUTDIR)SuperNode.$(O) \
    $(OUTDIR)SyntaxHighlighter.$(O) \
    $(OUTDIR)extensions.$(O) \