Make.spec
author Claus Gittinger <cg@exept.de>
Mon, 16 Feb 2009 14:10:39 +0100
changeset 2165 4dde25bad190
parent 2017 3cc93cf90c54
child 2248 1d5d6c463fe2
permissions -rw-r--r--
automatic checkIn

# $Header$
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libcomp.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libcomp
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optinline


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_OBJS= \
    $(OUTDIR)ParseNode.$(O) \
    $(OUTDIR)MessageNode.$(O) \
    $(OUTDIR)BlockNode.$(O) \
    $(OUTDIR)Scanner.$(O) \
    $(OUTDIR)CascadeNode.$(O) \
    $(OUTDIR)CompilationErrorHandler.$(O) \
    $(OUTDIR)PrimaryNode.$(O) \
    $(OUTDIR)Parser.$(O) \
    $(OUTDIR)Explainer.$(O) \
    $(OUTDIR)ImmutableArray.$(O) \
    $(OUTDIR)ImmutableString.$(O) \
    $(OUTDIR)LazyMethod.$(O) \
    $(OUTDIR)BinaryNode.$(O) \
    $(OUTDIR)ObjectFileHandle.$(O) \
    $(OUTDIR)ObjectFileLoader.$(O) \
    $(OUTDIR)ParseErrorNode.$(O) \
    $(OUTDIR)AssignmentNode.$(O) \
    $(OUTDIR)ByteCodeCompiler.$(O) \
    $(OUTDIR)ParserFlags.$(O) \
    $(OUTDIR)ConstantNode.$(O) \
    $(OUTDIR)StatementNode.$(O) \
    $(OUTDIR)ProgramNode.$(O) \
    $(OUTDIR)ProgramNodeBuilder.$(O) \
    $(OUTDIR)ProgramNodeEnumerator.$(O) \
    $(OUTDIR)ReturnNode.$(O) \
    $(OUTDIR)STCCompilerInterface.$(O) \
    $(OUTDIR)Decompiler.$(O) \
    $(OUTDIR)SelfNode.$(O) \
    $(OUTDIR)SourceFileLoader.$(O) \
    $(OUTDIR)PrimitiveNode.$(O) \
    $(OUTDIR)Structure.$(O) \
    $(OUTDIR)SuperNode.$(O) \
    $(OUTDIR)Switch.$(O) \
    $(OUTDIR)SyntaxHighlighter.$(O) \
    $(OUTDIR)UnaryNode.$(O) \
    $(OUTDIR)UndefinedVariable.$(O) \
    $(OUTDIR)Variable.$(O) \
    $(OUTDIR)VariableNode.$(O) \
    $(OUTDIR)WarningCompilationErrorHandler.$(O) \
    $(OUTDIR)stx_libcomp.$(O) \
    $(OUTDIR)extensions.$(O) \