Make.spec
author Claus Gittinger <cg@exept.de>
Fri, 30 Apr 2010 12:01:30 +0200
changeset 2376 e90d8b65c910
parent 2362 6768a1b26cc9
child 2438 38c58eb9f28c
permissions -rw-r--r--
automatically generated by browser

# $Header$
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libcomp.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libcomp
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optinline


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	ParseNode \
	MessageNode \
	BlockNode \
	Scanner \
	CascadeNode \
	CompilationErrorHandler \
	PrimaryNode \
	Parser \
	Explainer \
	LazyMethod \
	BinaryNode \
	ObjectFileHandle \
	ObjectFileLoader \
	ParseErrorNode \
	AssignmentNode \
	ByteCodeCompiler \
	ParserFlags \
	ConstantNode \
	StatementNode \
	ProgramNode \
	ProgramNodeBuilder \
	ProgramNodeEnumerator \
	ReturnNode \
	STCCompilerInterface \
	Decompiler \
	SelfNode \
	SourceFileLoader \
	PrimitiveNode \
	Structure \
	SuperNode \
	Switch \
	AbstractSyntaxHighlighter \
	SyntaxHighlighter \
	UnaryNode \
	UndefinedVariable \
	Variable \
	VariableNode \
	WarningCompilationErrorHandler \
	stx_libcomp \
	DoNotShowCompilerWarningAgainActionQuery \
	InstrumentedMethod \
	InstrumentingCompiler \
	CodeCoverageHighlighter \




COMMON_OBJS= \
    $(OUTDIR)ParseNode.$(O) \
    $(OUTDIR)MessageNode.$(O) \
    $(OUTDIR)BlockNode.$(O) \
    $(OUTDIR)Scanner.$(O) \
    $(OUTDIR)CascadeNode.$(O) \
    $(OUTDIR)CompilationErrorHandler.$(O) \
    $(OUTDIR)PrimaryNode.$(O) \
    $(OUTDIR)Parser.$(O) \
    $(OUTDIR)Explainer.$(O) \
    $(OUTDIR)LazyMethod.$(O) \
    $(OUTDIR)BinaryNode.$(O) \
    $(OUTDIR)ObjectFileHandle.$(O) \
    $(OUTDIR)ObjectFileLoader.$(O) \
    $(OUTDIR)ParseErrorNode.$(O) \
    $(OUTDIR)AssignmentNode.$(O) \
    $(OUTDIR)ByteCodeCompiler.$(O) \
    $(OUTDIR)ParserFlags.$(O) \
    $(OUTDIR)ConstantNode.$(O) \
    $(OUTDIR)StatementNode.$(O) \
    $(OUTDIR)ProgramNode.$(O) \
    $(OUTDIR)ProgramNodeBuilder.$(O) \
    $(OUTDIR)ProgramNodeEnumerator.$(O) \
    $(OUTDIR)ReturnNode.$(O) \
    $(OUTDIR)STCCompilerInterface.$(O) \
    $(OUTDIR)Decompiler.$(O) \
    $(OUTDIR)SelfNode.$(O) \
    $(OUTDIR)SourceFileLoader.$(O) \
    $(OUTDIR)PrimitiveNode.$(O) \
    $(OUTDIR)Structure.$(O) \
    $(OUTDIR)SuperNode.$(O) \
    $(OUTDIR)Switch.$(O) \
    $(OUTDIR)AbstractSyntaxHighlighter.$(O) \
    $(OUTDIR)SyntaxHighlighter.$(O) \
    $(OUTDIR)UnaryNode.$(O) \
    $(OUTDIR)UndefinedVariable.$(O) \
    $(OUTDIR)Variable.$(O) \
    $(OUTDIR)VariableNode.$(O) \
    $(OUTDIR)WarningCompilationErrorHandler.$(O) \
    $(OUTDIR)stx_libcomp.$(O) \
    $(OUTDIR)DoNotShowCompilerWarningAgainActionQuery.$(O) \
    $(OUTDIR)InstrumentedMethod.$(O) \
    $(OUTDIR)InstrumentingCompiler.$(O) \
    $(OUTDIR)CodeCoverageHighlighter.$(O) \
    $(OUTDIR)extensions.$(O) \