tests/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Wed, 03 Jan 2018 22:19:22 +0000
branchjv
changeset 8269 5382a417a503
parent 8224 6d994e1ee4fc
child 8618 2bb91659ca1f
permissions -rw-r--r--
Issue #190: added tests for `Image class >> fromView:` and `Image class >> fromScreen:' ...which broke under XWayland since XWayland does not support `XGetImage()` https://swing.fit.cvut.cz/projects/stx-jv/ticket/190

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libview_tests.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libview/tests
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	FcPatternTests \
	FormTests \
	ImageTests \
	ResourcePackTests \
	stx_libview_tests \




COMMON_OBJS= \
    $(OUTDIR)FcPatternTests.$(O) \
    $(OUTDIR)FormTests.$(O) \
    $(OUTDIR)ImageTests.$(O) \
    $(OUTDIR)ResourcePackTests.$(O) \
    $(OUTDIR)stx_libview_tests.$(O) \