tests/Make.spec
author Jan Vrany <jan.vrany@labware.com>
Fri, 26 Apr 2024 21:09:50 +0100
branchjv
changeset 9076 7c39b306d9d4
parent 8703 215db3ae79d1
permissions -rw-r--r--
Skip `FcPatternTests >> test_02` when using FontConfig >= 2.13.1 ...as it turns out the "bug" is still present in 2.14.1 and 2.15.0. Sigh.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libview_tests.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libview/tests
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	FontTests \
	FormTests \
	ImageTests \
	ResourcePackTests \
	SimpleViewTests \
	stx_libview_tests \

UNIX_CLASSES= \
	FcPatternTests \




COMMON_OBJS= \
    $(OUTDIR)FontTests.$(O) \
    $(OUTDIR)FormTests.$(O) \
    $(OUTDIR)ImageTests.$(O) \
    $(OUTDIR)ResourcePackTests.$(O) \
    $(OUTDIR)SimpleViewTests.$(O) \
    $(OUTDIR)stx_libview_tests.$(O) \

UNIX_OBJS= \
    $(OUTDIR)FcPatternTests.$(O) \