Make.spec
changeset 2983 305bf156cd3d
parent 2979 1a7c0e6ca59d
child 2991 a004f068a836
equal deleted inserted replaced
2982:7579c3a3a9b4 2983:305bf156cd3d
     1 # $Header: /cvs/stx/stx/libwidg2/Make.spec,v 1.7 2006-08-18 14:05:42 cg Exp $
     1 # $Header: /cvs/stx/stx/libwidg2/Make.spec,v 1.8 2006-08-21 15:38:45 cg Exp $
     2 #
     2 #
     3 # -------------- no need to change anything below ----------
     3 # DO NOT EDIT 
       
     4 # automagically generated from the projectDefinition: stx_libwidg2.
       
     5 #
       
     6 # Warning: once you modify this file, do not rerun
       
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
       
     8 #
       
     9 # This file contains specifications which are common to all platforms.
       
    10 #
     4 
    11 
       
    12 # Do NOT CHANGE THESE DEFINITIONS
       
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
       
    14 #  to find the source code of a class and to find the library for a package)
     5 MODULE=stx
    15 MODULE=stx
     6 MODULE_DIR=libwidg2
    16 MODULE_DIR=libwidg2
     7 LIBNAME=libstx_libwidg2
    17 LIBNAME=libstx_libwidg2
     8 PACKAGE=$(MODULE):$(MODULE_DIR)
       
     9 THIS_IS_A_BASE_LIBRARY="yes"
       
    10 
    18 
    11 OBJS= \
    19 
    12 	$(LIBWIDG2_PACKAGE_OBJS) \
    20 # Argument(s) to the stc compiler (stc --usage).
    13 	$(OUTDIR)LicenceBox.$(O)         \
    21 #  -H.         : create header files locally
    14 	$(OUTDIR)SubCanvas.$(O)          \
    22 #                (if removed, they will be created as common
    15 	$(OUTDIR)Slider.$(O)             \
    23 #  -Pxxx       : defines the package
    16 	$(OUTDIR)HorizontalSlider.$(O)   \
    24 #  -Zxxx       : a prefix for variables within the classLib
    17 	$(OUTDIR)LabelledEnterField.$(O) \
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    18 	$(OUTDIR)FilenameEnterBox.$(O)   \
    26 #  -Ixxx       : include path passed to CC for inline C-code
    19 	$(OUTDIR)FilenameEditField.$(O)  \
    27 #  +optspace   : optimized for space
    20 	$(OUTDIR)CheckBox.$(O)           \
    28 #  +optspace2  : optimized more for space
    21 	$(OUTDIR)Separator.$(O)          \
    29 #  +optspace3  : optimized even more for space
    22 	$(OUTDIR)TabulatorSpecification.$(O) \
    30 #  +optinline  : generate inline code for some ST constructs
    23 	$(OUTDIR)TabSpecRuler.$(O)       \
    31 #  +inlineNew  : additionally inline new
    24 	$(OUTDIR)ListEntry.$(O)          \
    32 #  +inlineMath : additionally inline some floatPnt math stuff
    25 	  $(OUTDIR)MultiColListEntry.$(O) \
    33 #
    26 	  $(OUTDIR)ModelListEntry.$(O)   \
    34 # ********** OPTIONAL: MODIFY the next line(s) ***
    27 	    $(OUTDIR)LabelAndIcon.$(O)   \
    35 # STCLOCALOPTIMIZATIONS=+optinline +inlineNew
    28 	$(OUTDIR)ComboView.$(O)          \
    36 # STCLOCALOPTIMIZATIONS=+optspace3
    29 	  $(OUTDIR)ComboBoxView.$(O)     \
    37 STCLOCALOPTIMIZATIONS=+optspace3
    30 	  $(OUTDIR)ComboListView.$(O)    \
    38 
    31 	$(OUTDIR)ComboBoxButton.$(O)     \
    39 
    32 	$(OUTDIR)FilenameComboBoxView.$(O)  \
    40 # Argument(s) to the stc compiler (stc --usage).
    33 	$(OUTDIR)MenuPanel.$(O)          \
    41 #  -warn            : no warnings
    34 	$(OUTDIR)SelectionInTreeView.$(O) \
    42 #  -warnNonStandard : no warnings about ST/X extensions
    35 	$(OUTDIR)SelectionInTree.$(O)    \
    43 #  -warnEOLComments : no warnings about EOL comment extension
    36 	$(OUTDIR)TreeItem.$(O)           \
    44 #  -warnPrivacy     : no warnings about privateClass extension
    37 	  $(OUTDIR)TreeItemWithImage.$(O) \
    45 #
    38 	$(OUTDIR)HierarchyNode.$(O)      \
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
    39 	$(OUTDIR)SelectionInHierarchy.$(O) \
    47 # STCWARNINGS=-warn
    40 	$(OUTDIR)NoteBookView.$(O)       \
    48 # STCWARNINGS=-warnNonStandard
    41 	$(OUTDIR)TabItem.$(O)            \
    49 # STCWARNINGS=-warnEOLComments
    42 	$(OUTDIR)TabView.$(O)            \
    50 STCWARNINGS=
    43 	$(OUTDIR)TabWidget.$(O)          \
    51 
    44 	$(OUTDIR)DataSetView.$(O)        \
    52 COMMON_OBJS= \
    45 	$(OUTDIR)DataSetColumn.$(O)      \
    53     CheckBox.$(O) \
    46 	$(OUTDIR)DataSetLabel.$(O)       \
    54     MenuPanel.$(O) \
    47 	$(OUTDIR)DSVLabelView.$(O)       \
    55     ComboBoxButton.$(O) \
    48 	$(OUTDIR)DSVColumnView.$(O)      \
    56     ComboView.$(O) \
    49 	$(OUTDIR)GridBagConstraints.$(O) \
    57     ComboListView.$(O) \
    50 	$(OUTDIR)GridBagLayoutInfo.$(O)  \
    58     ComboBoxView.$(O) \
    51 	$(OUTDIR)GridBagLayoutView.$(O)  \
    59     DSVColumnView.$(O) \
    52 	$(OUTDIR)UpDownButton.$(O)       \
    60     DSVLabelView.$(O) \
    53 	$(OUTDIR)ViewScroller.$(O)       \
    61     DataSetColumn.$(O) \
    54 	$(OUTDIR)FileSelectionTree.$(O)  \
    62     DataSetLabel.$(O) \
    55 	$(OUTDIR)FileSelectionItem.$(O)  \
    63     DataSetView.$(O) \
    56 	$(OUTDIR)TextBox.$(O)            \
    64     DoWhatIMeanSupport.$(O) \
    57 	$(OUTDIR)EnterBoxWithList.$(O)   \
    65     EnterBoxWithList.$(O) \
    58 	$(OUTDIR)HierarchicalItem.$(O)   \
    66     ExtendedComboBox.$(O) \
    59 	  $(OUTDIR)HierarchicalItemWithLabel.$(O)   \
    67     TreeItem.$(O) \
    60 	    $(OUTDIR)HierarchicalItemWithLabelAndIcon.$(O)   \
    68     SelectionInTreeView.$(O) \
    61 	      $(OUTDIR)HierarchicalItemWithLabelAndIconAndValue.$(O)   \
    69     FilenameComboBoxView.$(O) \
    62 	$(OUTDIR)ListModelView.$(O)      \
    70     FilenameEditField.$(O) \
    63 	$(OUTDIR)SelectionInListModelView.$(O) \
    71     FilenameEnterBox.$(O) \
    64 	$(OUTDIR)HierarchicalListView.$(O) \
    72     FontMenu.$(O) \
    65 	$(OUTDIR)HierarchicalList.$(O)    \
    73     GridBagConstraints.$(O) \
    66 	$(OUTDIR)HierarchicalFileList.$(O) \
    74     GridBagLayoutInfo.$(O) \
    67 	$(OUTDIR)ExtendedComboBox.$(O) \
    75     GridBagLayoutView.$(O) \
    68 	$(OUTDIR)SyncedMultiColumnTextView.$(O) \
    76     HierarchicalItem.$(O) \
    69 	$(OUTDIR)TwoColumnTextView.$(O) \
    77     HierarchicalList.$(O) \
    70 	$(OUTDIR)MultipleItemSelectionWidget.$(O) \
    78     HierarchicalItemWithLabel.$(O) \
    71 	$(OUTDIR)ProgressIndicator.$(O) \
    79     HierarchicalItemWithLabelAndIcon.$(O) \
    72 	$(OUTDIR)ImageView.$(O) \
    80     HierarchicalItemWithLabelAndIconAndValue.$(O) \
    73 	$(OUTDIR)DoWhatIMeanSupport.$(O) \
    81     HierarchicalFileList.$(O) \
    74 	$(OUTDIR)ColorMenu.$(O) \
    82     ListModelView.$(O) \
    75 	$(OUTDIR)FontMenu.$(O) \
    83     HierarchyNode.$(O) \
    76 	$(OUTDIR)PrintingDialog.$(O) \
    84     Slider.$(O) \
    77 	$(OUTDIR)PrintAbortDialog.$(O) \
    85     ImageView.$(O) \
       
    86     ImageEditView.$(O) \
       
    87     ListEntry.$(O) \
       
    88     LabelledEnterField.$(O) \
       
    89     ModelListEntry.$(O) \
       
    90     SelectionInListModelView.$(O) \
       
    91     ColorMenu.$(O) \
       
    92     LabelAndIcon.$(O) \
       
    93     MultiColListEntry.$(O) \
       
    94     MultipleItemSelectionWidget.$(O) \
       
    95     NoteBookView.$(O) \
       
    96     PrintAbortDialog.$(O) \
       
    97     PrintingDialog.$(O) \
       
    98     ProgressIndicator.$(O) \
       
    99     SelectionInHierarchy.$(O) \
       
   100     HierarchicalListView.$(O) \
       
   101     SelectionInTree.$(O) \
       
   102     FileSelectionTree.$(O) \
       
   103     Separator.$(O) \
       
   104     HorizontalSlider.$(O) \
       
   105     SubCanvas.$(O) \
       
   106     SyncedMultiColumnTextView.$(O) \
       
   107     TabItem.$(O) \
       
   108     TabSpecRuler.$(O) \
       
   109     TabView.$(O) \
       
   110     TabWidget.$(O) \
       
   111     TabulatorSpecification.$(O) \
       
   112     TextBox.$(O) \
       
   113     ThreeColumnTextView.$(O) \
       
   114     FileSelectionItem.$(O) \
       
   115     TreeItemWithImage.$(O) \
       
   116     TwoColumnTextView.$(O) \
       
   117     UpDownButton.$(O) \
       
   118     ViewScroller.$(O) \
       
   119     stx_libwidg2.$(O) \
       
   120 
       
   121