Make.spec
changeset 2983 305bf156cd3d
parent 2979 1a7c0e6ca59d
child 2991 a004f068a836
--- a/Make.spec	Mon Aug 21 17:38:42 2006 +0200
+++ b/Make.spec	Mon Aug 21 17:38:45 2006 +0200
@@ -1,77 +1,121 @@
-# $Header: /cvs/stx/stx/libwidg2/Make.spec,v 1.7 2006-08-18 14:05:42 cg Exp $
+# $Header: /cvs/stx/stx/libwidg2/Make.spec,v 1.8 2006-08-21 15:38:45 cg Exp $
+#
+# DO NOT EDIT 
+# automagically generated from the projectDefinition: stx_libwidg2.
 #
-# -------------- no need to change anything below ----------
+# Warning: once you modify this file, do not rerun
+# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
+#
+# This file contains specifications which are common to all platforms.
+#
 
+# Do NOT CHANGE THESE DEFINITIONS
+# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
+#  to find the source code of a class and to find the library for a package)
 MODULE=stx
 MODULE_DIR=libwidg2
 LIBNAME=libstx_libwidg2
-PACKAGE=$(MODULE):$(MODULE_DIR)
-THIS_IS_A_BASE_LIBRARY="yes"
+
+
+# Argument(s) to the stc compiler (stc --usage).
+#  -H.         : create header files locally
+#                (if removed, they will be created as common
+#  -Pxxx       : defines the package
+#  -Zxxx       : a prefix for variables within the classLib
+#  -Dxxx       : defines passed to to CC for inline C-code
+#  -Ixxx       : include path passed to CC for inline C-code
+#  +optspace   : optimized for space
+#  +optspace2  : optimized more for space
+#  +optspace3  : optimized even more for space
+#  +optinline  : generate inline code for some ST constructs
+#  +inlineNew  : additionally inline new
+#  +inlineMath : additionally inline some floatPnt math stuff
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
+# STCLOCALOPTIMIZATIONS=+optspace3
+STCLOCALOPTIMIZATIONS=+optspace3
+
+
+# Argument(s) to the stc compiler (stc --usage).
+#  -warn            : no warnings
+#  -warnNonStandard : no warnings about ST/X extensions
+#  -warnEOLComments : no warnings about EOL comment extension
+#  -warnPrivacy     : no warnings about privateClass extension
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCWARNINGS=-warn
+# STCWARNINGS=-warnNonStandard
+# STCWARNINGS=-warnEOLComments
+STCWARNINGS=
 
-OBJS= \
-	$(LIBWIDG2_PACKAGE_OBJS) \
-	$(OUTDIR)LicenceBox.$(O)         \
-	$(OUTDIR)SubCanvas.$(O)          \
-	$(OUTDIR)Slider.$(O)             \
-	$(OUTDIR)HorizontalSlider.$(O)   \
-	$(OUTDIR)LabelledEnterField.$(O) \
-	$(OUTDIR)FilenameEnterBox.$(O)   \
-	$(OUTDIR)FilenameEditField.$(O)  \
-	$(OUTDIR)CheckBox.$(O)           \
-	$(OUTDIR)Separator.$(O)          \
-	$(OUTDIR)TabulatorSpecification.$(O) \
-	$(OUTDIR)TabSpecRuler.$(O)       \
-	$(OUTDIR)ListEntry.$(O)          \
-	  $(OUTDIR)MultiColListEntry.$(O) \
-	  $(OUTDIR)ModelListEntry.$(O)   \
-	    $(OUTDIR)LabelAndIcon.$(O)   \
-	$(OUTDIR)ComboView.$(O)          \
-	  $(OUTDIR)ComboBoxView.$(O)     \
-	  $(OUTDIR)ComboListView.$(O)    \
-	$(OUTDIR)ComboBoxButton.$(O)     \
-	$(OUTDIR)FilenameComboBoxView.$(O)  \
-	$(OUTDIR)MenuPanel.$(O)          \
-	$(OUTDIR)SelectionInTreeView.$(O) \
-	$(OUTDIR)SelectionInTree.$(O)    \
-	$(OUTDIR)TreeItem.$(O)           \
-	  $(OUTDIR)TreeItemWithImage.$(O) \
-	$(OUTDIR)HierarchyNode.$(O)      \
-	$(OUTDIR)SelectionInHierarchy.$(O) \
-	$(OUTDIR)NoteBookView.$(O)       \
-	$(OUTDIR)TabItem.$(O)            \
-	$(OUTDIR)TabView.$(O)            \
-	$(OUTDIR)TabWidget.$(O)          \
-	$(OUTDIR)DataSetView.$(O)        \
-	$(OUTDIR)DataSetColumn.$(O)      \
-	$(OUTDIR)DataSetLabel.$(O)       \
-	$(OUTDIR)DSVLabelView.$(O)       \
-	$(OUTDIR)DSVColumnView.$(O)      \
-	$(OUTDIR)GridBagConstraints.$(O) \
-	$(OUTDIR)GridBagLayoutInfo.$(O)  \
-	$(OUTDIR)GridBagLayoutView.$(O)  \
-	$(OUTDIR)UpDownButton.$(O)       \
-	$(OUTDIR)ViewScroller.$(O)       \
-	$(OUTDIR)FileSelectionTree.$(O)  \
-	$(OUTDIR)FileSelectionItem.$(O)  \
-	$(OUTDIR)TextBox.$(O)            \
-	$(OUTDIR)EnterBoxWithList.$(O)   \
-	$(OUTDIR)HierarchicalItem.$(O)   \
-	  $(OUTDIR)HierarchicalItemWithLabel.$(O)   \
-	    $(OUTDIR)HierarchicalItemWithLabelAndIcon.$(O)   \
-	      $(OUTDIR)HierarchicalItemWithLabelAndIconAndValue.$(O)   \
-	$(OUTDIR)ListModelView.$(O)      \
-	$(OUTDIR)SelectionInListModelView.$(O) \
-	$(OUTDIR)HierarchicalListView.$(O) \
-	$(OUTDIR)HierarchicalList.$(O)    \
-	$(OUTDIR)HierarchicalFileList.$(O) \
-	$(OUTDIR)ExtendedComboBox.$(O) \
-	$(OUTDIR)SyncedMultiColumnTextView.$(O) \
-	$(OUTDIR)TwoColumnTextView.$(O) \
-	$(OUTDIR)MultipleItemSelectionWidget.$(O) \
-	$(OUTDIR)ProgressIndicator.$(O) \
-	$(OUTDIR)ImageView.$(O) \
-	$(OUTDIR)DoWhatIMeanSupport.$(O) \
-	$(OUTDIR)ColorMenu.$(O) \
-	$(OUTDIR)FontMenu.$(O) \
-	$(OUTDIR)PrintingDialog.$(O) \
-	$(OUTDIR)PrintAbortDialog.$(O) \
+COMMON_OBJS= \
+    CheckBox.$(O) \
+    MenuPanel.$(O) \
+    ComboBoxButton.$(O) \
+    ComboView.$(O) \
+    ComboListView.$(O) \
+    ComboBoxView.$(O) \
+    DSVColumnView.$(O) \
+    DSVLabelView.$(O) \
+    DataSetColumn.$(O) \
+    DataSetLabel.$(O) \
+    DataSetView.$(O) \
+    DoWhatIMeanSupport.$(O) \
+    EnterBoxWithList.$(O) \
+    ExtendedComboBox.$(O) \
+    TreeItem.$(O) \
+    SelectionInTreeView.$(O) \
+    FilenameComboBoxView.$(O) \
+    FilenameEditField.$(O) \
+    FilenameEnterBox.$(O) \
+    FontMenu.$(O) \
+    GridBagConstraints.$(O) \
+    GridBagLayoutInfo.$(O) \
+    GridBagLayoutView.$(O) \
+    HierarchicalItem.$(O) \
+    HierarchicalList.$(O) \
+    HierarchicalItemWithLabel.$(O) \
+    HierarchicalItemWithLabelAndIcon.$(O) \
+    HierarchicalItemWithLabelAndIconAndValue.$(O) \
+    HierarchicalFileList.$(O) \
+    ListModelView.$(O) \
+    HierarchyNode.$(O) \
+    Slider.$(O) \
+    ImageView.$(O) \
+    ImageEditView.$(O) \
+    ListEntry.$(O) \
+    LabelledEnterField.$(O) \
+    ModelListEntry.$(O) \
+    SelectionInListModelView.$(O) \
+    ColorMenu.$(O) \
+    LabelAndIcon.$(O) \
+    MultiColListEntry.$(O) \
+    MultipleItemSelectionWidget.$(O) \
+    NoteBookView.$(O) \
+    PrintAbortDialog.$(O) \
+    PrintingDialog.$(O) \
+    ProgressIndicator.$(O) \
+    SelectionInHierarchy.$(O) \
+    HierarchicalListView.$(O) \
+    SelectionInTree.$(O) \
+    FileSelectionTree.$(O) \
+    Separator.$(O) \
+    HorizontalSlider.$(O) \
+    SubCanvas.$(O) \
+    SyncedMultiColumnTextView.$(O) \
+    TabItem.$(O) \
+    TabSpecRuler.$(O) \
+    TabView.$(O) \
+    TabWidget.$(O) \
+    TabulatorSpecification.$(O) \
+    TextBox.$(O) \
+    ThreeColumnTextView.$(O) \
+    FileSelectionItem.$(O) \
+    TreeItemWithImage.$(O) \
+    TwoColumnTextView.$(O) \
+    UpDownButton.$(O) \
+    ViewScroller.$(O) \
+    stx_libwidg2.$(O) \
+
+