Make.spec
changeset 3603 9e0abf12938f
parent 3203 3d66c67515a7
child 3614 07036b722893
equal deleted inserted replaced
3602:ca4228ee4d3c 3603:9e0abf12938f
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    21 #  -headerDir=. : create header files locally
    21 #  -headerDir=. : create header files locally
    22 #                (if removed, they will be created as common
    22 #                (if removed, they will be created as common
    23 #  -Pxxx       : defines the package
    23 #  -Pxxx       : defines the package
    24 #  -Zxxx       : a prefix for variables within the classLib
    24 #  -Zxxx       : a prefix for variables within the classLib
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    25 #  -Dxxx       : defines passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    27 #  +optspace   : optimized for space
    27 #  +optspace   : optimized for space
    28 #  +optspace2  : optimized more for space
    28 #  +optspace2  : optimized more for space
    29 #  +optspace3  : optimized even more for space
    29 #  +optspace3  : optimized even more for space
    30 #  +optinline  : generate inline code for some ST constructs
    30 #  +optinline  : generate inline code for some ST constructs
    78 
    78 
    79 
    79 
    80 
    80 
    81 
    81 
    82 COMMON_OBJS= \
    82 COMMON_OBJS= \
    83     $(OUTDIR_SLASH)ColorEditDialog.$(O) \
    83     $(OUTDIR)ColorEditDialog.$(O) \
    84     $(OUTDIR_SLASH)DataSetBuilder.$(O) \
    84     $(OUTDIR)DataSetBuilder.$(O) \
    85     $(OUTDIR_SLASH)DirectoryView.$(O) \
    85     $(OUTDIR)DirectoryView.$(O) \
    86     $(OUTDIR_SLASH)FlyByWindowInformation.$(O) \
    86     $(OUTDIR)FlyByWindowInformation.$(O) \
    87     $(OUTDIR_SLASH)ImageEditor.$(O) \
    87     $(OUTDIR)ImageEditor.$(O) \
    88     $(OUTDIR_SLASH)MenuEditor.$(O) \
    88     $(OUTDIR)MenuEditor.$(O) \
    89     $(OUTDIR_SLASH)MethodFinderWindow.$(O) \
    89     $(OUTDIR)MethodFinderWindow.$(O) \
    90     $(OUTDIR_SLASH)SelectionBrowser.$(O) \
    90     $(OUTDIR)SelectionBrowser.$(O) \
    91     $(OUTDIR_SLASH)TabListEditor.$(O) \
    91     $(OUTDIR)TabListEditor.$(O) \
    92     $(OUTDIR_SLASH)Tools__ObjectModuleInformation.$(O) \
    92     $(OUTDIR)Tools__ObjectModuleInformation.$(O) \
    93     $(OUTDIR_SLASH)ProjectBuilder.$(O) \
    93     $(OUTDIR)ProjectBuilder.$(O) \
    94     $(OUTDIR_SLASH)Tools__ProjectBuilderAssistantApplication.$(O) \
    94     $(OUTDIR)Tools__ProjectBuilderAssistantApplication.$(O) \
    95     $(OUTDIR_SLASH)UIGalleryView.$(O) \
    95     $(OUTDIR)UIGalleryView.$(O) \
    96     $(OUTDIR_SLASH)UIHelpTool.$(O) \
    96     $(OUTDIR)UIHelpTool.$(O) \
    97     $(OUTDIR_SLASH)UILayoutTool.$(O) \
    97     $(OUTDIR)UILayoutTool.$(O) \
    98     $(OUTDIR_SLASH)UIListEditor.$(O) \
    98     $(OUTDIR)UIListEditor.$(O) \
    99     $(OUTDIR_SLASH)UIObjectView.$(O) \
    99     $(OUTDIR)UIObjectView.$(O) \
   100     $(OUTDIR_SLASH)UIPainter.$(O) \
   100     $(OUTDIR)UIPainter.$(O) \
   101     $(OUTDIR_SLASH)UISelectionPanel.$(O) \
   101     $(OUTDIR)UISelectionPanel.$(O) \
   102     $(OUTDIR_SLASH)UISpecificationTool.$(O) \
   102     $(OUTDIR)UISpecificationTool.$(O) \
   103     $(OUTDIR_SLASH)stx_libtool2.$(O) \
   103     $(OUTDIR)stx_libtool2.$(O) \
   104     $(OUTDIR_SLASH)FileSelectionBrowser.$(O) \
   104     $(OUTDIR)FileSelectionBrowser.$(O) \
   105     $(OUTDIR_SLASH)ResourceSelectionBrowser.$(O) \
   105     $(OUTDIR)ResourceSelectionBrowser.$(O) \
   106     $(OUTDIR_SLASH)UIPainterView.$(O) \
   106     $(OUTDIR)UIPainterView.$(O) \
   107     $(OUTDIR_SLASH)extensions.$(O) \
   107     $(OUTDIR)extensions.$(O) \
   108 
   108 
   109 
   109 
   110 
   110